Help Center> Elastic Cloud Server> FAQs> Network Configurations> EIPs> Why Is Outbound Access on TCP Port 25 Blocked?
Updated on 2023-04-26 GMT+08:00

Why Is Outbound Access on TCP Port 25 Blocked?

Symptom

You cannot access an external address on TCP port 25. For example, running the Telnet smtp.***.com 25 command fails.

Cause

For security reasons, TCP port 25 is disabled in the outbound direction by default.

You do not need to enable TCP port 25, unless you want to deploy an email service on the cloud.

This section applies to CN-Hong Kong only.

Solution

  • Use port 465 supported by the third-party email service provider.
  • Apply to enable TCP port 25 in the outbound direction.

    If you must enable TCP port 25 on the ECS for external communications, submit an application.

Before submitting your application, you must agree to and guarantee that TCP port 25 is only used to connect to third-party Simple Mail Transfer Protocol (SMTP) servers and that emails are sent using the third-party SMTP servers. If you use the EIP specified in the service ticket to directly send emails over SMTP, TCP port 25 will be permanently disabled and you can no longer use it or request it be enabled.

  1. On the Create Service Ticket page, choose Products > Elastic Cloud Server.
  2. Click Open Port 25 under Select Subtype and create a service ticket.

    For details about how to submit a service ticket, see Submitting a Service Ticket.

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