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Help Center/ Elastic Cloud Server/ Troubleshooting/ Windows ECS Issues/ How Do I Troubleshoot Unavailable Input Methods?

How Do I Troubleshoot Unavailable Input Methods?

Updated on 2023-03-03 GMT+08:00

Symptom

  • On your Windows ECS, you cannot switch input methods using Ctrl+Shift. The input method is not shown.
  • You do not know how to add a language to the input methods.

Possible Causes

  • The ctfmon.exe process is not started.
  • The input indication icon is turned off.

Solutions to Unavailable Input Methods

Check whether the ctfmon.exe process is started.

  1. Open the C:\Windows\System32 file.
  2. Double-click ctfmon.exe and check whether the input method is shown in the lower right corner and whether you can switch the input method.
  1. Enable the automatic input method startup upon ECS startup.
    1. In the Run dialog box, enter regedit and click OK to open the registry editor.
    2. In the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run directory, create a file named ctfmon.exe in string type.
      Figure 1 Registry Editor
    3. Right-click the file you create and click Modify. Change the value data to C:\Windows\System32\ctfmon.exe in which ctfmon.exe is stored.
      Figure 2 Editing the value data
    4. In the Run dialog box, enter msconfig and click OK to open the System Configuration.
    5. Click the Start tab, find and select ctfmon.exe, and click Apply and OK. Save the configurations and log out. Restart the ECS.
      Figure 3 Selecting ctfmon.exe

Enable the input indication icon.

  1. Log in to the ECS and click Customize in the lower right corner.
    Figure 4 Clicking Customize
  2. In the Notification Area Icon window, click Turn system icons on or off.
    Figure 5 Turning system icons on or off
  3. Set Input Indicator to On and click OK.
    Figure 6 Turning input indicator on

Adding Another Input Language

For example, add Japanese on an ECS running Windows Server 2008.

  1. Log in to the ECS and open the control panel.
  2. Click Region and Language.
    Figure 7 Region and Language
  3. On the Keyboards and Languages tab, click Change keyboards.
    Figure 8 Keyboards and Languages
  4. Right-click the language bar and click Settings to open the Text Services and Input Languages dialog box. On the General tab, click Add.
    Figure 9 Text Services and Input Languages
  5. In the Add Input Language dialog box, find and double-click Japanese (Japan) and then Keyboard.
    Figure 10 Adding input language
  6. Select Japanese and Microsoft IME. Click OK and then Apply to save the configurations.
    Figure 11 Selecting Japanese

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