Help Center> Elastic Cloud Server> Troubleshooting> BSOD Issues> Why Does BSOD Occur When I Log In to an ECS Using Remote Desktop Connection?
Updated on 2023-03-03 GMT+08:00

Why Does BSOD Occur When I Log In to an ECS Using Remote Desktop Connection?

Symptom

When you attempt to use a remote desktop connection to log in to an ECS running Windows Server 2012 R2 from a local computer with redirected drive enabled, blue screen of death (BSOD) occurs.

Root Cause

The remote desktop connection with redirected drive enabled loads the desired rdpdr.sys drive, which leads to BSOD and error code 0x18, 0x50, 0xa, 0x27, or 0x133.

Solution

After you enable the remote desktop connection, disable redirect local drives.

  1. Start the Run dialog box.
  2. Enter mstsc and click OK.

    The Remote Desktop Connection window is displayed.

  3. Click Options in the lower left corner and click the Local Resources tab.
  4. In the Local devices and resources pane, click More.
  5. Deselect Drives.
  6. Click OK.
    Figure 1 Disabling redirect local drives