Help Center> Elastic Cloud Server> FAQs> Login and Connection> Remote Login Errors on Windows> Why Does the System Display No Remote Desktop License Servers Available to Provide a License When I Log In to a Windows ECS?
Updated on 2022-12-13 GMT+08:00

Why Does the System Display No Remote Desktop License Servers Available to Provide a License When I Log In to a Windows ECS?

Symptom

An error message is displayed indicating that there are no Remote Desktop License Servers available to provide a license and asks you to contact the administrator.

Figure 1 No Remote Desktop License Servers available to provide a license

Possible Causes

You have installed the Remote Desktop Session Host.

The grace period for Remote Desktop Services is 120 days. If you do not pay for it when the period expires, the service will stop. Windows allows a maximum of two users (including the local user) in remote desktop connections. To allow the access of more users, install the Remote Desktop Session Host and configure the desired number of authorized users. However, installing the Remote Desktop Session Host will automatically revoke the original two free connections. This leads to the preceding fault if desired number of authorized users has not been configured.

Solution

  • Method 1: Apply for a license for authenticating multi-user sessions and activate the ECS. Note that you need to purchase a remote desktop access license from the official Microsoft website.

    For details, see How Do I Apply for a License for Authenticating Multi-User Sessions and Activate an ECS?

  • Method 2: Delete Remote Desktop Session Host (Windows Server 2008) or Remote Desktop Services (Windows Server 2012).

    After you delete the role, the ECS allows a maximum of two users (including local login users) to access.

  • Method 3: Reconfigure multi-user login after reinstalling or changing the ECS OS.

    Windows Server 2008 public images are no longer supported. If you are using a Windows Server 2008 ECS, change its OS to a Windows Server 2012 OS.

    Back up data on the system disk before reinstalling or changing the OS.

Precautions

  • The operations described in this section apply to the ECSs running a Windows Server 2008 or Windows Server 2012.
  • The ECS must be restarted during the operation, which may interrupt services. Back up data before restarting the ECS.

Windows Server 2008

  1. Log in to the Windows ECS using VNC available on the management console.
  2. Open Server Manager, right-click Remote Desktop Services under Roles, and choose Remove Roles from the shortcut menu.
    Figure 2 Deleting roles
  3. In the displayed dialog box, deselect Remote Desktop Session Host and keep clicking Next till you finish the operation.
    Figure 3 Deselecting Remote Desktop Session Host
  4. Click Delete.
  5. Restart the ECS.

Windows Server 2012

  1. Log in to the Windows ECS using VNC available on the management console.
  2. Open Server Manager, choose Manage > Remove Roles and Features, and click Next.
    Figure 4 Deleting roles and features
  3. Select the destination server and click Next.
  4. Deselect Remote Desktop Services.
    Figure 5 Deselecting Remote Desktop Services
  5. Click Delete.
  6. Restart the ECS.

Remote Login Errors on Windows FAQs

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