Help Center> Elastic Cloud Server> Troubleshooting> BSOD Issues> How Do I Fix a BSOD on a Windows ECS?
Updated on 2023-03-03 GMT+08:00

How Do I Fix a BSOD on a Windows ECS?

Symptom

A blue screen of death (BSOD) occurs on a Windows ECS, as shown in Figure 1.

Figure 1 Bugcheck code and module that may cause the BSOD

Possible Causes

  1. Third-party software from unknown sources is used.
  2. The CPU usage is too high.
  3. System files and registries are damaged due to misoperations or viruses.

When a BSOD occurs, the system displays a bugcheck code and the module that may cause this error.

Visit Bug Check Code Reference to learn about solutions provided by Microsoft.

Solution

  1. Do not install software from unknown sources and use authorized software. Windows 2012 is recommended.
  2. If the ECS is created using an external image, see "Optimizing a Windows Private Image" in Image Management Service User Guide.
  3. If the BSOD is caused by high CPU usage, perform the following operations to reduce the CPU usage:
    • Stop the processes that are not being used and try again.
    • Restart the ECS.
    • Back up important data and reinstall the OS.
    • If the OS cannot be reinstalled due to important data, replace the disk attached to the ECS. To do so, back up the data on the original disk, detach the disk from the ECS, attach the new disk to the ECS, and copy the data to the new disk.
  4. If you need to analyze the BSOD cause, check whether crash dump files are generated in the specified directory.

    Analyzing BSOD logs is time-consuming. You are advised to restart the ECS and identify the fault based on the preceding possible causes. The common causes are third-party antivirus software, system faults, and high CPU usage.