Help Center > > FAQs> Login and Connection> Login Preparations> What Should I Do If Starting an ECS Remains in "Waiting for cloudResetPwdAgent" State?

What Should I Do If Starting an ECS Remains in "Waiting for cloudResetPwdAgent" State?

Updated at: Dec 16, 2019 GMT+08:00

Symptom

During ECS startup, it remains in "Waiting for cloudResetPwdAgent" state for 20-30 seconds.

Figure 1 Starting cloudResetPwdAgent

Possible Causes

This issue is caused by the intranet DNS and user-defined DNS configurations.

Solution

  1. Log in to the ECS as user root.
  2. Run the following command to modify the /etc/cloud/cloud.cfg configuration file:

    vi /etc/cloud/cloud.cfg

  3. Add the following statement to the configuration file:

    manage_etc_hosts: true

    Figure 2 Editing the configuration file

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