Help Center> Elastic Cloud Server> User Guide (Kuala Lumpur Region)> FAQs> Login and Connection> Why Am I Seeing an Error Message That Says User Account is not Authorized for Remote Login When I Log In to a Windows ECS?
Updated on 2022-08-16 GMT+08:00

Why Am I Seeing an Error Message That Says User Account is not Authorized for Remote Login When I Log In to a Windows ECS?

Symptom

An error message is displayed indicating that the connection is denied because the user account is not authorized for remote login.

Figure 1 Error message

Possible Causes

The remote desktop connection permissions have been incorrectly configured.

Solution

  1. Check remote desktop permissions on the ECS.

    1. In the Run dialog box, enter secpol.msc and click OK to open Local Security Policy.
    2. Choose Local Policies > User Rights Assignment > Allow log on through Remote Desktop Services.
      Figure 2 Local security policy
    3. Check whether there are user groups or users that have been granted the remote login permission.

      If not, add required users or groups.

      Figure 3 Allow log on through Remote Desktop Services properties

  2. Check the target user group.

    1. Open the Run dialog box, enter lusrmgr.msc, and click OK to open Local Users and Groups.
    2. Double-click Users on the left.
    3. Double-click the name of the user to whom the login error message was displayed.
    4. In the displayed dialog box, click the Member Of tab. Ensure that the user belongs to the user group that is assigned with the remote login permission in 2.b.
      Figure 4 Checking the target user group

  3. Check the remote desktop session host configuration.

    1. In the Run dialog box, enter tsconfig.msc and click OK to open Remote Desktop Session Host Configuration.
    2. Double-click RDP-Tcp or other connections added by a user under Connections and click the Security tab.
      Figure 5 Security
    3. Check whether there are user groups or users that have been granted the remote login permission under Group or user names.

      If not, add required users or groups.

    4. Restart the ECS or run the following commands in the CLI to restart the Remote Desktop Services:

      net stop TermService

      net start TermService