Help Center> Elastic Cloud Server> FAQs> Passwords and Key Pairs> Key Pairs> Why Does a Key Pair Created Using puttygen.exe Fail to Be Imported on the Management Console?
Updated on 2022-12-13 GMT+08:00

Why Does a Key Pair Created Using puttygen.exe Fail to Be Imported on the Management Console?

Symptom

When you try to import a key pair that you created using puttygen.exe on the management console, the system displays a message indicating that the import failed.

Possible Causes

The format of the public key content does not meet system requirements.

If you store a public key by clicking Save public key on PuTTY Key Generator, the format of the public key content will change. Therefore, you cannot import the key on the management console.

Solution

Use the locally stored private key and PuTTY Key Generator to restore the format of the public key content. Then, import the public key to the management console.

  1. Double-click puttygen.exe to open PuTTY Key Generator.
    Figure 1 PuTTY Key Generator
  2. Click Load and select the private key.

    The system automatically loads the private key and restores the format of the public key content in PuTTY Key Generator. The content in the red box in Figure 2 is the public key whose format meets system requirements.

    Figure 2 Restoring the format of the public key content
  3. Copy the public key content to a .txt file and save the file in a local directory.
  4. Import the public key to the management console.
    1. Log in to the management console.
    2. Click in the upper left corner and select your region and project.
    3. Under Compute, click Elastic Cloud Server.
    4. In the navigation pane on the left, choose Key Pair.
    5. On the key pair page, click Import Key Pair.
    6. Copy the public key content in the .txt file to Public Key Content and click OK.

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