What Should I Do If Attaching a Disk to a Windows ECS Failed But There Are Still Available Device Names?
Symptom
On the Windows ECS details page, the system displays a message indicating that at most n more disks can be attached to the ECS. However, after you clicked Attach Disk, the attachment failed.
![Click to enlarge](https://support.huaweicloud.com/intl/en-us/ecs_faq/en-us_image_0219699754.png)
Possible Causes
If an EVS disk in arrears is not renewed, the system forcibly uninstalls it, which may cause a residual drive letter on the Windows ECS. As a result, the actual number of available device names on the ECS is less than the displayed number.
Solution
Restart the ECS and attach the disk again.
If the attaching still fails, contact customer service for technical support.
Disk Attachment FAQs
- Can I Attach Multiple Disks to an ECS?
- What Are the Requirements for Attaching an EVS Disk to an ECS?
- Which ECSs Can Be Attached with SCSI EVS Disks?
- How Do I Obtain My Disk Device Name in the ECS OS Using the Device Identifier Provided on the Console?
- What Should I Do If Attaching a Disk to a Windows ECS Failed But There Are Still Available Device Names?
- Why Does a Linux ECS with a SCSI Disk Attached Fails to Be Restarted?
- How Can I Check Whether the ECSs Attached with the Same Shared SCSI Disk Are in the Same ECS Group?
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbotmore