How Do I Fix an Abnormal Agent?
Your agent is probably abnormal if it is in Not installed or Offline state. Agent statuses and their meaning are as follows:
- Uninstalled: No agent has been installed on the server, or the agent has been installed but not started.
- Offline: The communication between the agent and the server is abnormal. The agent on the server has been deleted, or a non-HUAWEI CLOUD server is offline.
- Online: The agent on the server is running properly.
Possible Causes
- The network is faulty.
The agent or the cloud protection center is abnormal. For example, the NIC is faulty, the IP address changes, or the bandwidth is low.
- The agent process is abnormal.
- The agent status has not been updated. After the agent is installed, it takes about 2 minutes for the console to update its status.
Solution
- Fix network problems (if any).
Ensure that the outbound configurations of the security group of your server allow access to port 10180 in the 100.125.0.0/16 network segment.
After the network recovers,
- If the agent status is Online, no further action is required.
- If the agent status is Not installed or Offline, go to 2.
- Log in to the server and restart the agent. The agent status Not installed or Offline indicates that the agent process is probably abnormal.
- Linux
Run the following command in the CLI as user root to restart the agent:
service hostguard restart
If the following information is displayed, the restart is successful:root@HSS-Ubuntu32:~#service hostguard restart Stopping Hostguard... Hostguard stopped Hostguard restarting... Hostguard is running
After the process is restarted, wait for about 2 minutes.
- If the agent status is Online, no further action is required.
- If the agent status is still Not installed or Offline, uninstall the agent and install it again.
- Linux
Agent FAQs FAQs
- Is the Agent in Conflict with Any Other Security Software?
- How Do I Install the Agent?
- How Do I Uninstall the Agent?
- What Should I Do If Agent Installation Failed?
- How Do I Fix an Abnormal Agent?
- What Is the Default Agent Installation Path?
- How Many CPU and Memory Resources Are Occupied by the Agent When It Performs Scans?
- Do WTP and HSS Use the Same Agent?
- How Do I View Servers Where No Agents Have Been Installed?
- What Can I Do If the Agent Status Is Still "Not installed" After Installation?
- How Do I Upgrade the Agent?
- What Do I Do If I Failed to Upgrade an Agent?
- What If I Do Not Upgrade from the HSS (Old) to the HSS (New) Version?
- Huawei Cloud ECS Would Access Which IP Addresses after Installing an Agent?
- How Do I Use Images to Install Agents in Batches?
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