Help Center/ Host Security Service/ FAQs/ Agent/ How Do I Fix an Abnormal Agent?
Updated on 2025-09-08 GMT+08:00

How Do I Fix an Abnormal Agent?

Your agent is probably abnormal if it is in Not installed or Offline state. Agent statuses and their meaning are as follows:

  • Uninstalled: No agent has been installed on the server, or the agent has been installed but not started.
  • Offline: The communication between the agent and the server is abnormal. The agent on the server has been deleted, or a non-Huawei Cloud server is offline.
  • Online: The agent on the server is running properly.

Possible Causes

  • The agent status on the console is not updated.

    The agent status has not been updated. After the agent is installed, it takes 5 to 10 minutes for the console to update its status.

  • OS version not supported.

    For details, see Supported OSs.

  • The network is faulty.

    The agent or the cloud protection center is abnormal. For example, the NIC is faulty, the IP address changes, or the bandwidth is low.

  • The server memory is insufficient.
  • The agent process is abnormal.

Solution

  1. The agent has been installed on the server for more than 10 minutes, but the agent status on the console is Offline or Not installed.

    • If yes, go to 2.
    • If no, wait until the agent goes online. No further action is required. After the agent is installed, it takes 5 to 10 minutes for the console to update its status.

  2. Check whether your server OS is within the scope of support in Supported OSs.

    • If yes, go to 3.
    • If no, the HSS agent cannot be installed or run on your server. Upgrade the OS to a version supported by HSS and try again.

  3. Check whether the server can access the network.

    • If yes, go to 4.
    • If no, restore its network connection, then check its agent status on the console.

  4. Check whether the server meets the following requirements:

    • CN East 2 and CN Southwest-Guiyang1 regions

      Check whether the VPC of your server has an endpoint named com.myhuaweicloud.xxx.hss-agent. For details, see Verifying the Network Connection. This endpoint is used for communication between your server and the HSS server.

      • If yes, go to 5.
      • If no, create a VPC endpoint by referring to Manually Setting Up a Connection. Creating a VPC endpoint is free. It will only occupy a VPC subnet IP address. After the creation is complete, wait for about 3 minutes. Then, go to the HSS console to check the agent status.
    • Regions other than CN East 2 and CN Southwest-Guiyang1

      Check whether the security group of your server allows outbound access to port 10180 in the 100.125.0.0/16 CIDR block.

      • If yes, go to 5.
      • If no, allow access to the port, wait for about 3 minutes, then go to the HSS console to check the agent status. For details about how to view and modify a security group, see Modifying a Security Group.

  5. Check whether the disk capacity of the server destined for agent installation is greater than 300 MB.

    On a Linux server, the agent is installed in the /usr/local/hostguard/ directory by default. Check whether the remaining capacity of the disk partition where the directory is located is greater than 300 MB. On a Windows server, the agent is installed in the C:\Program Files\HostGuard directory by default. Check whether the remaining capacity of drive C is greater than 300 MB.

    • If yes, go to 6.
    • If no, the agent will go offline due to insufficient server memory. After the capacity expansion is complete, the agent will go online again.

  6. If the agent process is abnormal, perform the following operations to restart it:

    • Windows
      1. Log in to the server as user administrator.
      2. Open the Task Manager.
      3. On the Services tab page, select HostGuard.
      4. Right-click the service and choose Restart.
    • Linux

      Run the following command in the CLI as user root to restart the agent:

      /etc/init.d/hostguard restart

      If the following information is displayed, the restart is successful:
      root@HSS-Ubuntu32:~#/etc/init.d/hostguard restart
      Stopping Hostguard...
      Hostguard stopped
      Hostguard restarting...
      Hostguard is running

    After the process is restarted, wait for about 2 minutes.

    • If the agent status is Online, no further action is required.
    • If the agent status is still Not installed or Offline, uninstall the agent and install it again.
      1. For details about the uninstallation method, see How Do I Uninstall the Agent?

        After the uninstallation is complete, wait for 5 to 10 minutes, ensure that the server is displayed on the Server Install & Config > Agents > Servers Without Agents page of the HSS console, and then install the agent.

      2. For details about how to install an agent, see Installing the Agent on Servers.

        If you install the agent by using commands on Huawei Cloud servers in the CN East 2 and CN Southwest-Guiyang1 regions, you can skip the steps of connecting to servers, because they are already connected.