Help Center> Host Security Service (New)> User Guide (Ankara Region)> FAQs> Agent FAQs> What Should I Do If Agent Installation Failed?
Updated on 2024-04-15 GMT+08:00

What Should I Do If Agent Installation Failed?

If this is the first time you install the agent, and the installation failed, rectify the fault by following the instructions provided in this section.

Symptoms

The agent fails to be installed by running commands. The server list page on the console still indicates that the agent is not installed.

Possible Causes

  • The SELinux firewall has not been disabled.
  • The root account is not used for installation.
  • The installation command is incorrect.
  • Residual information exists after the agent is uninstalled.

Solution

  1. Check whether the SELinux firewall of the server is disabled.

    • If it is, go to the next step.
    • If it is not, disable it and install the agent again.

  2. Check whether the installation command is suitable for the server region and OS.

    1. Switch to the server region.
    2. Copy the installation commands suitable for your server OS.
      • Run 32-bit installation commands on a 32-bit server.
      • Run 64-bit installation commands on a 64-bit server.
    • If yes, go to the next step.
    • If the commands you used are incorrect, install the agent again with correct ones.

  3. Check whether the installation was performed by user root.

    • If yes, go to the next step.
    • If it was not, install the agent again as user root.

  4. Uninstall the agent as user root and forcibly install it.

    • If the installation is successful, no further action is required.
    • If the installation fails, contact technical support.