Help Center> Cloud Search Service> Troubleshooting> Functions> Error Message "maximum shards open" Is Displayed When I Create an Index
Updated on 2023-02-02 GMT+08:00

Error Message "maximum shards open" Is Displayed When I Create an Index

Symptom

When I create an index, an error message is displayed: "this action would add [2] total shards, but this cluster currently has [1000]/[1000] maximum shards open".

Possible Cause

By default, each node can support up to 1000 shards. An error is reported if you keep allocating new shards to a node, making the number of shards reach the upper limit.

Solution

  1. Disable or delete unused indexes to reduce the number of shards.
  2. Change the maximum number of shards allowed on a node.
    PUT _cluster/settings
    {
    "persistent": {
    "cluster": {
    "max_shards_per_node": 2000
    }
    }
    }