Help Center> Cloud Search Service> Troubleshooting> Functions> An Error Message Is Displayed When I Change the Read-Only Status of an Index
Updated on 2023-02-02 GMT+08:00

An Error Message Is Displayed When I Change the Read-Only Status of an Index

Symptom

If the space of a security cluster is used up, all indexes become read-only. The value of the parameter read_only_allow_delete is true. Data can only be read from but cannot be written to the indexes. In this case, I run the following command to manually change the value of the read_only_allow_delete parameter to false:

PUT _settings
{
"index": {
"blocks": {
"read_only_allow_delete": "false"
}
}
}

The error information is as follows:

{
"error": {
"root_cause": [
{
"type": "security_exception",
"reason": "no permissions for [] and User [name=admin, roles=[admin], requestedTenant=null]"
}
],
"type": "security_exception",
"reason": "no permissions for [] and User [name=admin, roles=[admin], requestedTenant=null]"
},
"status": 403
}

Possible Causes

By default, a security cluster has an opendistro_security index, which cannot be written. You need to skip this index when changing the status of indexes.

Solution

Use wildcards to match specified indexes. (Use a wildcard to replace the indexname in the following example.)

PUT indexname/_settings
{
"index": {
"blocks": {
"read_only_allow_delete": "false"
}
}
}