Help Center/ Cloud Search Service/ Troubleshooting/ Unavailable Clusters/ A Cluster is Unavailable Due to Plugin Incompatibility
Updated on 2025-10-11 GMT+08:00

A Cluster is Unavailable Due to Plugin Incompatibility

Symptom

After a custom plugin is installed and the cluster is restarted, the cluster status changes to Unavailable.

Click the cluster name to go to the cluster basic information page, choose Logs, and click the Log Search tab. The following plug-in error message is displayed: "fatal error in thread [main], exitingjava.lang. NoClassDefFoundError: xxx/xxx/.../xxxPlugin at ...".

Figure 1 Node error logs

CSS has discontinued the custom plugin function. Clusters of earlier versions that have installed custom plugins may become unavailable.

Possible Causes

An installed custom plugin is incompatible with the current CSS cluster version. As a result, the Elasticsearch process cannot be started properly.

Procedure

  1. On the Clusters page, click the name of the unavailable cluster. The cluster information page is displayed.
  2. Choose Cluster Settings > Plugins.
  3. Click the Custom Plugins tab, find the custom plugin, and determine whether to continue to it.
    • If yes, delete the plugin and reinstall it.
      1. In the custom plugin operation list, uninstall and delete the target plugin.
      2. Rectify the plugin fault based on the error information in the node logs. If the fault persists, contact technical support.
      3. After the plugin fault is rectified, upload and install the target plugin in the custom plugin operation list. If the plugin status is Installed and to be effective upon cluster restart, the plugin is successfully installed.
    • If no, delete the plugin.

      In the custom plugin operation list, uninstall and delete the target plugin.

  4. In the upper right corner, click Restart.
  5. After the cluster is restarted, the cluster becomes available.