Help Center> Cloud Search Service> Troubleshooting> Unavailable Clusters> A Cluster is Unavailable Due to Incompatible Data Types
Updated on 2023-06-21 GMT+08:00

A Cluster is Unavailable Due to Incompatible Data Types

Symptom

After a cluster is restored using backup or migrated, the cluster status changes to Unavailable.

Possible Causes

Some types of the restored data are not supported by the destination cluster. For example, some plugins or settings are installed in the old cluster, which are not supported by the new cluster. As a result, index shards cannot be allocated.

Procedure

  1. On the Dev Tools page of Kibana, run the GET _cluster/allocation/explain?pretty command to check the reason why index shards are not allocated.
  2. The value of index and explanation in the output are as follows, indicating that the shard backup is not activated.
    Figure 1 Unallocated index shards
  3. Modify the configuration of the index and run the following command to set the number of copies to 0:
    PUT /index_name/_settings
    {  
      "number_of_replicas": 0
    }

    The value of reason indicates that some types of the data that is being restored are not supported by the CSS cluster.

    Figure 2 Incompatible data
  4. According to the root cause, delete the data type that is not supported by the current CSS cluster or select a CSS cluster version that supports the data type, and then restore the backup or migrate the data.