Help Center/ Cloud Search Service/ Troubleshooting/ Clusters/ An Elasticsearch Cluster Reports Error Message "unassigned shards all indices"
Updated on 2025-10-11 GMT+08:00

An Elasticsearch Cluster Reports Error Message "unassigned shards all indices"

Symptom

An Elasticsearch cluster reports error message unassigned shards all indices and the cluster status is red.

Possible Causes

Unallocated shards exist in the current cluster.

Solution

  1. Log in to Kibana.
    1. Log in to the CSS management console.
    2. In the navigation pane on the left, choose Clusters > Elasticsearch.
    3. In the cluster list, find the target cluster, and click Kibana in the Operation column to log in to the Kibana console.
    4. In the left navigation pane, choose Dev Tools.
  2. Run the following command to re-allocate unallocated shards:
    POST  /_cluster/reroute?retry_failed=true