文档首页/ 弹性云服务器 ECS/ 常见问题/ 远程登录/ 远程连接类/ 为什么单击“获取密码”后,系统提示查询不到密码?
更新时间:2024-11-01 GMT+08:00
分享

为什么单击“获取密码”后,系统提示查询不到密码?

问题描述

用户登录Windows操作系统的弹性云服务器时,需使用密码方式登录。因此需通过密钥文件,获取该弹性云服务器的初始密码。但是,用户参见获取Windows弹性云服务器的密码内容单击“获取密码”后,系统提示查询不到密码,导致用户无法登录弹性云服务器。

可能原因

根据Windows弹性云服务器使用的镜像不同,可能会存在如下原因:

  • 原因一:Windows弹性云服务器的镜像为用户自己制作的私有镜像,且在创建该私有镜像时未安装Cloudbase-init工具。
  • 原因二:Windows弹性云服务器的镜像安装了Cloudbase-init工具,但是在创建弹性云服务器时,获取密钥失败。

处理方法

  • 针对原因一:

    创建私有镜像时不安装Cloudbase-init工具,将无法对弹性云服务器进行自定义配置,此时,用户只能使用镜像原有密码登录弹性云服务器

    其中,镜像原有密码指用户创建私有镜像时,给操作系统设置的密码。

    如果忘记镜像原有密码,可以通过弹性云服务器页面提供的“重置密码”功能,自助完成弹性云服务器的密码重置。

  • 针对原因二:
    1. 勾选待获取密码的弹性云服务器,单击“重启”,重新启动弹性云服务器
    2. 重启成功后,选择“操作”列下的“更多 > 获取密码”,查看是否可以成功获取密码。
      • 是,结束。
      • 否,请联系客服寻求技术支持。

相关文档