更新时间:2023-05-31 GMT+08:00
输入法无法使用怎么办?
问题描述
- 登录云服务器后无法切换输入法,按ctrl+shift不生效,右下角不显示输入法栏。
- 想切换其他语言的输入法怎么办?
可能原因
- 因为ctfmon.exe进程没有启动导致的
- 关闭了输入指示系统图标
输入法不显示处理方法
方法一:检查是否启动了ctfmon.exe进程。
- 打开C:\Windows\System32,
- 双击运行ctfmon.exe,查看右下角是否显示输入法栏,能否切换输入法。
- 设置开机自启动:
- 在运行窗口输入“regedit”回车,打开注册表编辑器。
- 在目录HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > Run下,新建一个注册表文件ctfmon.exe。
图1 Run目录
- 修改字符串的数值数据为ctfmon.exe的存储位置:C:\Windows\System32\ctfmon.exe
图2 修改字符串的数值数据
- 在运行窗口输入“msconfig”,打开“系统配置使用程序”。
- 选择“启动”页,找到ctfmon项并在其前面打上钩,分别再单击“应用”和“确定”保存修改后退出,重启云服务器后即可生效。
图3 勾选ctfmon项
方法二:启用系统图标
- 登录云服务器,在云服务器右下角单击“自定义”。
图4 单击“自定义”
- 在通知区域图标页面,单击“启用或关闭系统图标”。
图5 启用或关闭系统图标
- 将输入指示选择启用,单击“确定”。
图6 启用输入指示
切换其他语言的输入法
以Windows 2008操作系统云服务器,切换日语输入法为例,:
- 登录云服务器,打开“控制面板”。
- 单击“区域和语言”选项。
图7 区域和语言
- 选择“键盘和语言”标签,并单击“更改键盘”。
图8 键盘和语言
- 打开“文本服务和输入语言”对话框,在“常规”标签中单击“添加”。
图9 文本服务和输入语言
- 在弹出的“添加输入语言”对话框中,找到“日语(日本)”。
图10 添加输入语言
- 双击“日语(日本)”展开,双击“键盘”子项展开,勾选“Microsoft IME”和“日语”,单击“确定”,分别再单击“应用”和“确定”保存修改后退出。
图11 选择日语
父主题: 操作系统类(Windows)