问题描述
登录Windows操作系统云服务器看不到挂载的数据盘。
格式化磁盘会造成数据丢失,请提前对数据盘创建备份,避免数据丢失。
可能原因
- 新添加的数据盘未进行分区和初始化。
- 切换操作系统或变更规格导致的磁盘脱机。
新添加的数据盘未进行分区和初始化
新的数据盘默认是没有分区和文件系统的,因此在资源管理器中不会显示,需要先手动执行初始化操作。
具体方法请参见初始化数据盘场景及磁盘分区形式介绍。
切换操作系统或变更规格导致的磁盘脱机
切换操作系统后可能会由于文件系统不一致导致数据盘无法显示;Windows云服务器器变更规格后,可能会发生磁盘脱机。
- 登录云服务器,打开cmd运行窗口,并输入“diskmgmt.msc”打开磁盘管理。
查看磁盘状态,磁盘可能显示为“脱机”。
- 将磁盘设置为“联机”状态。
在磁盘列表中,单击脱机的磁盘,并选择“联机”,将脱机磁盘进行联机。
图1 磁盘联机
- 再次在“计算机”中查询数据盘是否显示正常。
如上述操作后磁盘仍未显示,可以重新进行磁盘初始化和分区的操作。格式化磁盘会造成数据丢失,请提前对数据盘创建备份,避免数据丢失。