文档首页/ 弹性云服务器 ECS/ 常见问题/ 远程登录/ Windows远程登录报错类/ RDP连接已断开,出现内部错误,错误代码4
更新时间:2024-11-01 GMT+08:00
分享

RDP连接已断开,出现内部错误,错误代码4

问题描述

Windows操作系统云服务器在登录时会遇到“出现了内部错误”提示,无法正常连接到服务器。这种情况一般都是远程服务太忙导致。

可能原因

Remote Desktop Services服务忙碌导致的登录异常。

远程桌面登录后断开连接,但未注销登录也可能会出现这个提示。为了避免类似情况,建议在不需要远程连接服务器时及时注销登录。

解决方法

  1. 通过控制台提供的VNC方式登录云服务器。
  2. 打开Windows搜索框,输入services,选择“服务”。
  3. 在服务中选择并重启Remote Desktop Services服务,请确保Remote Desktop Services状态为“正在运行”。
    图1 Remote Desktop Services
  4. 重试远程连接。

    如果仍然无法连接还可以尝试在本地主机以管理员身份运行cmd,执行netsh winsock reset恢复网络连接的默认配置,执行后重试远程连接。

相关文档