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更新时间:2024-12-18 GMT+08:00
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使用SSH登录Linux云服务器时提示“Permission denied, please try again.”错误

问题描述

使用SSH登录Linux云服务器时,输入正确的用户名和密码后,也无法正常登录。

执行cat /var/log/secure命令查看secure日志时提示如下错误信息。

Permission denied, please try again.
error: Could not get shadow infromation for root.

可能原因

Linux系统启用了SELinux服务,导致root用户和普通用户无法登录。

您可以根据实际情况,选择临时或永久关闭SELinux服务解决SSH连接异常问题。

检查SELinux服务状态

  1. 通过VNC方式登录Linux实例。
  2. 执行以下命令,查看当前SELinux服务状态。

    /usr/sbin/sestatus –v

    系统返回如下信息。

    SELinux status: enabled

    其中,SELinux status参数值说明如下:

    • enabled:SELinux服务处于开启状态。
    • disabled:SELinux服务处于关闭状态。

临时关闭SELinux服务

  1. 通过VNC方式登录Linux实例。
  2. 执行如下命令,临时关闭SELinux。

    setenforce 0

临时修改SELinux服务状态,实时生效,无需重启系统或实例。

永久关闭SELinux服务

  1. 通过VNC方式登录Linux实例。
  2. 执行如下命令,永久关闭SELinux服务。

    sed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/selinux/config

    此命令只适用当前SELinux服务为enforcing状态时使用。

  3. 重启Linux实例。

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