Incremental Synchronization Error: relation '%s' does not exist
Scenarios
During incremental synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: insert %s failed:tid: %s, sqno: %s, ERROR: relation ' %s' does not exist.
Possible Causes
The possible causes are as follows:
- The filter conditions of the DDL statement for creating tables in the source database are not executed in the destination database during synchronization. As a result, the tables do not exist in the destination database.
- The tables are deleted from the destination database.
- Filtering conditions are set for DDL statements during synchronization. Some DDL statements (such as rename) are filtered out. As a result, the destination database table does not exist.
Solution
For the first two causes, create a table in the destination database based on the table structure in the source database.
If some DDL statements are filtered out, rename the temporary table to the correct table name in the destination database.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.