Incremental Synchronization Error: Table %s not found in target database
Scenarios
During incremental synchronization, an error is reported, and the log information is as follows: INCREMENT failed, cause by: Table %s not found in target database.
Possible Causes
The possible causes are as follows:
- The filter conditions of DDL statements for creating tables in the source database are not synchronized to the destination database.
- As a result, tables are deleted from the destination database.
- Some DDL statements (such as rename) are filtered out during online DDL.
Solution
For the first two causes, create a table in the destination database based on the table structure in the source database.
If some DDLs are filtered out, rename the temporary table to the correct table name in the destination database.
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