Updated on 2022-09-21 GMT+08:00

Full Phase Error: Access denied for user %s

Scenarios

During a full or increment migration or synchronization, an error is reported. The log information is as follows: service %s failed, cause by: Unable to connect to DBMS: url=***?useUnicode=true&allowLoadLocalInfile=false&characterEncoding=UTF-8&connectTimeout=5000&useSSL=false&allowPublicKeyRetrieval=true&verifyServerCertificate=false&serverTimezone=UTC user=%s, Caused by: Access denied for user %s

Possible Causes

The possible cause is as follows:

  • Failed to connect to the source or destination database.

Solution

  1. Check whether the source or destination database is running properly.
  2. Check whether the password for connecting to the source or destination database is correct.
  3. Check whether the network connection between the DRS instance and the source database is normal.
  4. Check whether the IP address of the DRS instance is allowed to access the source or destination database.