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Full Phase Error: Table '%s ' already exists

Updated on 2022-09-21 GMT+08:00

Scenarios

During a full migration or synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: apply event=[type=table_rename_or_copy, index=null, schema_name= %s, object_name= %s] occur error, msg=rename table %s. %s error: Table '%s ' already exists.

Possible Causes

The possible causes are as follows:

  • The table without a primary key already exists in the destination database.

Solution

Contact the O&M engineers to delete the tables that do not have primary keys from the destination database table. After that, click Resume in the Operation column to resume the task.

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