Full Phase Error: transfer account failed, can not find password from src DB
Scenarios
During a full migration, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: transfer account failed, can not find password from src DB.
Possible Causes
- The RDS security policy does not allow the user password to be empty. However, if the source database is an on-premises MySQL database, the user password can be empty.
Solution
- Run the following SQL statement in the source database to query users whose passwords are empty:
- MySQL 5.7 or later versions:
SELECT USER,HOST,authentication_string FROM MYSQL.user WHERE authentication_string IS NULL OR authentication_string='';
- MySQL 5.6 and earlier versions
SELECT USER,HOST,`password` FROM MYSQL.user WHERE `password` IS NULL OR `password`='';
- MySQL 5.7 or later versions:
- Run the following SQL statement to delete the users whose passwords are empty from the source database or set passwords for the users:
- Delete a user whose password is empty.
DROP USER XXX@XXX;
- Set a password for a user.
ALTER USER xxx@xxx IDENTIFIED BY xxx;
- Delete a user whose password is empty.
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