Help Center> Data Replication Service> FAQs> Real-Time Migration> What Can I Do When Message "can not get agency token" Is Displayed in the Migration Log
Updated on 2023-07-03 GMT+08:00

What Can I Do When Message "can not get agency token" Is Displayed in the Migration Log

Possible Causes

The subaccount used for creating a task does not have an agency. As a result, automatic functions such as scheduled task startup fail to be executed. The typical scenarios are as follows:

  • When creating a task and setting the task to start as scheduled, you need to use account entrustment. Otherwise, the scheduled task fails to be started, leaving message "can not get agency token".
  • After a full+incremental task is started and the full migration is complete, you need to use account entrustment. Otherwise, the task will not enter the incremental phase, leaving message "can not get agency token".

Solution

Two solutions are provided as follows:

  • Method 1: Use your primary account to create a task and select Start at a specified time for Start Time.
  • Method 2: Use the primary account to add the Security Administrator permission to the user group to which the subaccount belongs. Then, create a task again, and select Start at a specified time for Start Time.
  • Method 3: Create a task again and select Start upon task creation for Start Time.

Real-Time Migration FAQs

more