更新时间:2022-03-21 GMT+08:00
分享

附录:CloudIDE使用方法

用户在编辑函数代码时支持类似工程方式的管理,可以创建文件、文件夹并对其进行编辑。使用函数工作流控制台中的在线代码编辑器,可以在线编写函数代码,如果代码是上传zip包的方式,则前端进行相应解压展示,并支持在线编辑修改。同时,在线代码编辑器支持在线测试和保存,可以查看函数执行的返回、执行摘要和日志,该功能需要在编辑器全屏模式下使用。

目录管理

在编辑器菜单栏中选择“文件”,可以管理文件夹目录,如图1所示。
图1 文件
在展开的下拉菜单中选择“新建文件”,可以新建文件,并命名,如图2所示。
图2 新建文件
在展开的下拉菜单中选择“新建模板”,可以选择模板在线创建函数,如图3所示。
图3 新建模板
选择需要的模板,创建在线函数,并命名,如图4所示。
图4 创建文件
点击右键,选择“重命名”可以对文件和文件夹进行重命名,选择“删除”可以删除,如图5所示。
图5 文件重命名

在左侧“文件”下拉菜单中选择“新建文件夹”,新建文件夹并命名,如图1中所示。

点击右键,选择“新建文件”可以在该文件夹目录下新建文件,在该菜单栏中,可以对文件夹重命名、新建Python模块、删除文件夹,如图6所示。
图6 编辑文件夹

在左侧“文件”下拉菜单中选择“关闭所有文件”,将所有打开的文件关闭,如图1中所示。

支持快速创建Python模块,支持多创建层级,如图7所示。
图7 多层级模块

代码在线编辑

在编辑器菜单栏中选择“编辑”,可以在线编辑代码。在下拉菜单中可以撤销操作或恢复上一步操作,也可以剪切内容等,如图8所示。
图8 在线编辑
在下拉菜单中选择“行”,可以对代码以“行”为单位进行编辑,如图9所示。
图9 编辑行

“行”命令的展开菜单中,选择“删除行”,可以删除整行代码。选择“删除左侧所有内容”,可以将鼠标光标所在位置左侧的代码删除,同样选择“删除右侧所有内容”,将右侧代码删除。选择“合并行”,将光标所在代码行的下一行代码合入到该行。

“编辑”下拉菜单中选择“注释”,可以编辑注释,如图10所示。
图10 编辑注释

“注释”命令的展开菜单中,选择“切换行注释”打开某一行代码的注释,选择“切换块注释”打开某一块代码的注释,选择“添加行注释”增加一行注释,选择“删除行注释”删除一行注释。

“编辑”下拉菜单中选择“折叠”,可以展开或折叠代码,如图11所示。
图11 展开或折叠代码

代码可以全部展开或折叠,按层级折叠请选择“Fold Level”

选择“排序”对代码行进行排序,如图12所示。
图12 排序

“编辑”菜单栏中同时可以裁剪尾随空格、转换大小写、设置文档格式等。

查找及替换

在编辑器菜单栏中选择“查找”,可以进行查找或替换。如图13所示。
图13 查找
在展开的下拉菜单中选择“查找”“替换”,输入内容,进行查找或替换代码,如图14所示。
图14 查找代码

跳转

在编辑菜单栏中选择“转到”,可以跳转到相应的代码位置,如图15所示。
图15 转到
在展开的下拉菜单中选择“转到行”,可以跳转到对应的代码行,如图16所示。
图16 跳转

当代码比较多时,选择一个反括号“{”,点击“转到括号”可跳转到相应的括号“}”位置,当代码中有错误时,点击“转到下一个问题(错误、告警、或信息)”跳转到下一个错误的地方。

函数在线测试

在编辑器全屏模式下,函数配置测试事件,点击“测试”测试函数,显示函数返回、执行摘要和日志,如图17所示。
图17 函数在线测试

通用功能

  1. 在编辑菜单栏中选择“查看”,在下拉的菜单栏中选择“主题”可以更换编辑器主题,选择“显示命令面板”可以查看所有命令,如图18所示。
    图18 查看所有命令
  2. 编辑器具有代码智能提示功能,如图19所示。
    图19 智能提示
  3. 支持左侧工作区域调整宽度,文件可以拖拽移动,同时本地文件可以拖拽上传。
分享:

    相关文档

    相关产品

close