Storage Disaster Recovery Service
Storage Disaster Recovery Service
- What's New
- Product Bulletin
- Service Overview
- Getting Started
-
User Guide
- Permissions Management
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Asynchronous Replication
- Managing a Replica Pair
- Managing a Protection Group
- Managing Protected Instances
- Managing DR Drills
- Managing Clients
- Synchronous Replication Management (for Installed Base Operations)
- Appendixes
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API Reference
- Before You Start
- API Overview
- Calling APIs
- Getting Started
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SDRS APIs
- Job
- API Version
- Active-Active Domain
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Protection Group
- Creating a Protection Group
- Querying Protection Groups
- Querying the Details of a Protection Group
- Deleting a Protection Group
- Changing the Name of a Protection Group
- Enabling Protection or Enabling Protection Again for a Protection Group
- Disabling Protection for a Protection Group
- Performing a Failover for a Protection Group
- Performing a Planned Failover for a Protection Group
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Protected Instance
- Creating a Protected Instance
- Deleting a Protected Instance
- Querying Protected Instances
- Querying Details About a Protected Instance
- Changing the Name of a Protected Instance
- Attaching a Replication Pair to a Protected Instance
- Detaching a Replication Pair from a Protected Instance
- Adding an NIC to a Protected Instance
- Deleting an NIC from a Protected Instance
- Modifying the Specifications of a Protected Instance
- Batch Creating Protected Instances
- Batch Deleting Protected Instances
- Replication Pair
- DR Drill
- Tag Management
- Task Center
- Tenant Quota Management
- Appendixes
- Change History
- SDK Reference
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FAQs
- Common Problems
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Synchronous Replication (for Installed Base Operations)
- Do I Need to Manually Create DR Resources?
- What Can I Do When the EIP Cannot Be Pinged After I Perform a Switchover for a Protection Group Containing a SUSE Server?
- What Can I Do If the NIC Names of the DR Drill Server and Production Site Server Are Different?
- What Can I Do If hostname of the Production Site Server and DR Site Server Are Different After a Switchover or Failover?
- Why NICs of DR Site Servers Are Not Displayed After I Perform a Failover?
- What Are the Precautions If the Production Site Server Uses the Key Login Mode?
- What Should I Pay Attention to When Logging In to the Server After the First Time Ever I Executed a Switchover, Failover, or DR Drill?
- How Do I Use a Resource Package?
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Asynchronous Replication
- How Do I Handle the drm Process Start Failure?
- Failed to Install and Configure Disaster Recovery Gateway When Process drm Exists But Port 7443 Is Not Listened
- What Can I Do If the Name of a Production Site Server or the Host Name Reported by the Gateway Is Incorrect and Always Displayed as "localhost"?
- What Can I Do If the Disaster Recovery Site VM Is Not Started After a Switchover?
- How Do I Obtain the Installation Package on a Production Site Server from the Gateway?
- How Do I Enable or Disable an ECS Firewall and Add a Port Exception to the Firewall?
- Why Can't I Find the Disaster Recovery Gateway When Associating a Replica Pair with It?
- Why Is No Production Site Server Displayed When I Create Protected Instances?
- Videos
- Glossary
- Best Practices
- General Reference
On this page
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How Do I Handle the drm Process Start Failure?
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How Do I Handle the drm Process Start Failure?
Symptom
The drm process failed to start after the disaster recovery gateway is deployed or proxy client is installed.
Possible Causes
Possible causes are as follows:
- Cause 1: The service account does not have the write permission on the /dev/null directory.
- Cause 2: The server cannot resolve the hostname domain name.
Solution 1
Assign the read and write permissions on the /dev/null directory to the service account.
- Log in to the server where the disaster recovery gateway or proxy client resides.
- Run the following command as user root to change the permission on the /dev/null directory:
chmod 666 /dev/null
- Run the following command to check the permission on the /dev/null directory:
ll /dev/null
The permission is successfully changed if information similar to the following is displayed:crw-rw-rw- 1 root root 1, 3 Apr 9 09:21 /dev/null
Solution 2
Add the domain name resolution of hostname.
- Log in to the server where the disaster recovery gateway or proxy client resides.
- Run the following command as user root to add the domain name resolution of hostname:
echo "127.0.0.1 `hostname`" >> /etc/hosts
- Run the following command to check whether the domain name resolution of hostname takes effect:
ping `hostname`
The configuration is successful if information similar to the following is displayed:PING test-dr (127.0.0.1) 56(84) bytes of data.64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.022 ms
Parent topic: Asynchronous Replication
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