文档首页> 云日志服务 LTS> 常见问题> 主机管理> ICAgent上报指标断点或无指标
更新时间:2024-04-18 GMT+08:00
分享

ICAgent上报指标断点或无指标

问题现象

ICAgent上报指标断点或无指标。

对系统的影响

影响用户查看指标监控。

可能原因

  1. 指标采集开关被关闭。
  2. 发送指标失败。

排查方法

  1. 检查指标采集开关是否关闭。

    1. 登录应用运维管理AOM控制台,选择“配置管理 > 指标配置”。
    2. 确认指标采集开关是否开启,若没有开启,需要开启指标采集开关。

  2. 后台查找指标采集开关配置。

    1. 登录ICAgent所在ecs主机。
    2. 执行“cd /var/ICAgent”进入ICAgent日志目录。
    3. 查找指标采集开关配置。
      cat oss.icAgent.trace| grep 'switchL'

    4. 如果查询不到,则过滤日志压缩包
      zgrep switchL *.zip

  3. 指标是否发送失败

    1. 登录ICAgent所在ecs的主机。
    2. 执行“cd /var/ICAgent”进入ICAgent日志目录。
    3. 查询指标发送失败日志
      cat oss.icAgent.trace | grep httpsend | grep MONITOR | grep failed

    4. 如果日志文件查询不到,则查找日志压缩包。
      zgrep httpsend *.zip| grep MONITOR | grep failed

分享:

主机管理 所有常见问题

more