在LTS页面无法查询新产生的日志怎么办?
问题现象
在LTS页面无法查询新产生的日志。
对系统的影响
导致用户无法查询业务日志。
可能原因
- LTS控制台上的“ICAgent采集开关”被关闭。
- ICAgent上报日志到LTS失败。
- 在LTS控制台设置的采集配置下发到ICAgent有误。
排查方法
请按如下步骤排查。
- 确认ICAgent采集开关是否开启。
- 登录云日志服务控制台。
- 选择“配置中心”。
- 在“ICAgent采集开关”页签,确认ICAgent采集开关是否开启。若没有开启,则需要开启ICAgent采集开关。
- 检查最近一次下发的ICAgent采集开关配置。
- 登录ICAgent所在的ECS主机。
- 执行cd /var/ICAgent进入ICAgent日志目录。
- 执行如下命令,查询日志采集配置。
zgrep switchList *.zip //查询已转储日志压缩包 cat oss.icAgent.trace | grep switchList //查询当前日志文件
从过滤结果查找日志时间最新的配置,并查看switch.log是否为true(代表开启ICAgent采集开关)。
- 检查ICAgent采集开关文件的内容switch.log是否为true(代表开启ICAgent采集开关)。
- 登录ICAgent所在的ECS主机。
- 查询ICAgent采集开关文件。
cat /var/share/oss/manager/ICProbeAgent/internal/TRACE_CONFIG/swithes_context.json
ICAgent采集开关文件的内容switch.log为true。
- 确认日志是否发送失败。
- 登录ICAgent所在ECS主机。
- 执行cd /var/ICAgent进入ICAgent日志目录。
- 查询发送失败日志。
cat oss.icAgent.trace | grep httpsend | grep 'dataType:TRACE' | grep failed zgrep 'dataType:TRACE' *.zip | grep httpsend | grep failed
若显示failed代表日志发送失败,则需要联系LTS技术支持工程师排查。
- 检查在LTS控制台设置的日志采集配置已下发到ICAgent。
- 登录ICAgent所在ECS主机。
- 执行cd /var/ICAgent进入ICAgent日志目录。
- 过滤日志文件查询LTS页面设置的日志采集配置。
cat oss.icAgent.trace | grep 'als event' | grep -v grep | tail -n 1
以上截图仅供参考,请以实际查询结果为准。从过滤结果查找用户实际设置的日志组、日志流以及采集路径,则确保日志采集配置已下发到ICAgent。
- 如果日志文件查询不到,则查询日志压缩包。
zgrep 'als event' *.zip | grep -v grep | tail -n 1
从日志压缩包查找用户实际设置的日志组、日志流以及采集路径,则确保日志采集配置已下发到ICAgent。
- 登录云日志服务LTS控制台,在日志接入页面,检查配置接入任务设置的日志采集配置。