更新时间:2024-01-03 GMT+08:00
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ALM-14000 HDFS服务不可用(2.x及以前版本)

告警解释

系统每30秒周期性检测NameService的服务状态,当检测到所有的NameService服务都异常时,就会认为HDFS服务不可用,此时产生该告警。

至少一个NameService服务正常后,系统认为HDFS服务恢复,告警清除。

告警属性

告警ID

告警级别

可自动清除

14000

致命

告警参数

参数名称

参数含义

ServiceName

产生告警的服务名称。

RoleName

产生告警的角色名称。

HostName

产生告警的主机名。

对系统的影响

无法为基于HDFS服务的HBase和MapReduce等上层部件提供服务。用户无法读写文件。

可能原因

  • ZooKeeper服务异常。
  • 所有NameService服务异常。

处理步骤

  1. 检查ZooKeeper服务状态。

    1. 登录MRS集群详情页面,在“组件管理”页签,查看ZooKeeper服务的健康状态是否为“良好”。
      • 是,执行1.b
      • 否,执行2.a
    2. 参考ALM-13000 ZooKeeper服务不可用(2.x及以前版本)对ZooKeeper服务状态异常进行处理,然后查看ZooKeeper服务的健康状态是否恢复为“良好”。
      • 是,执行1.c
      • 否,执行3
    3. 等待5分钟后,在“告警管理”页面,查看本告警是否恢复。
      • 是,处理完毕。
      • 否,执行2.a

  2. 处理NameService服务异常告警。

    1. 登录MRS集群详情页面,在“告警管理”页面查看所有NameService服务是否存在异常告警。
      • 是,执行2.b
      • 否,执行3
    2. 按照ALM-14010 NameService服务异常(2.x及以前版本)的处理方法,依次对这些服务异常的NameService进行处理,然后查看是否消除各个NameService服务异常告警。
      • 是,执行2.c
      • 否,执行3
    3. 等待5分钟后,在“告警管理”页签,查看该告警是否恢复。
      • 是,处理完毕。
      • 否,执行3

  3. 收集故障信息。

    1. 在MRS Manager界面,单击“系统设置 > 日志导出”。
    2. 请联系运维人员,并发送已收集的故障日志信息。

参考信息

无。

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