更新时间:2024-09-23 GMT+08:00
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ALM-12110 获取ECS临时ak/sk失败

告警解释

meta每五分钟调用ECS接口获取AK/SK信息,并缓存在meta中,在AK/SK过期失效之前会再次调用ECS接口更新AK/SK,如果连续三次调用接口失败,会产生该告警。

当meta服务调用ECS接口成功时,告警清除。

告警属性

告警ID

告警级别

是否自动清除

12110

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名称。

对系统的影响

集群获取不到最新的临时AK/SK,存算分离场景下,可能导致访问OBS失败,引起组件业务无法正常处理。

可能原因

  • MRS集群meta角色状态异常。
  • 集群绑定过委托且访问过OBS,但是已经解绑了,现在未绑定委托。

处理步骤

检查meta角色状态。

  1. 在集群的FusionInsight Manager页面,选择“运维 > 告警 > 告警”,单击此告警所在行的,确定该告警的主机地址。
  2. 在集群的FusionInsight Manager页面,选择“集群 > 服务 > meta”,单击“实例”,查看告警产生的主机对应的meta角色状态是否正常。

    • 是,执行5
    • 否,执行3

  3. 勾选状态异常的角色,选择“更多 > 重启实例”重启异常状态的meta角色。

    重启期间服务业务可能受损或中断,建议选择业务低峰期操作。

  4. 查看当前告警是否恢复。

    • 是,操作结束。
    • 否,执行5

  5. 登录1查询到主机地址,查看“/var/log/Bigdata/meta/mrs-meta.log”日志中是否有报错,根据日志进行排查处理。
  6. 查看当前告警是否恢复。

    • 是,操作结束。
    • 否,执行7

重新绑定委托

  1. 登录MapReduce服务管理控制台。
  2. 选择“现有集群”,单击集群名称,进入集群概览页面,在运维管理区域,查看集群是否绑定委托。

    • 是,执行10
    • 否,执行9

  3. 单击“委托管理”,重新绑定委托,等待几分钟后查看告警是否恢复。

    • 是,操作结束。
    • 否,执行10

收集故障信息

  1. 在主集群的FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选“meta”,单击“确定”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

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