更新时间:2024-12-06 GMT+08:00

ALM-45000 HetuEngine服务不可用

告警解释

系统每300秒周期性检测HetuEngine服务状态,当检测到HetuEngine服务不可用时产生该告警。

HetuEngine服务恢复时,告警清除。

告警属性

告警ID

告警级别

是否自动清除

45000

紧急

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

HetuEngine服务异常,无法通过FusionInsight Manager对HetuEngine集群进行操作,无法使用HetuEngine服务功能。

可能原因

  • KrbServer服务异常
  • ZooKeeper服务异常
  • HDFS服务异常
  • Yarn服务异常
  • DBService服务异常
  • Hive服务异常
  • HetuEngine缺少HSBroker实例

处理步骤

检查KrbServer服务状态。

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”。
  2. 在告警列表中,查看是否有“ALM-25500 KrbServer服务不可用”告警产生。

    • 是,执行3
    • 否,执行5

  3. 参考ALM-25500 KrbServer服务不可用告警帮助指导处理该告警。
  4. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行5

检查ZooKeeper服务状态。

  1. 在告警列表中,查看是否有“ALM-12007 进程故障”告警产生。

    • 是,执行6
    • 否,执行9

  2. 在告警列表中,单击“进程故障”告警所在行的。从“定位信息”中查看产生该告警的“服务名”是否为“ZooKeeper”

    • 是,执行7
    • 否,执行9

  3. 参考ALM-12007 进程故障告警帮助指导处理该告警。
  4. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行9

检查HDFS服务状态。

  1. 在告警列表中,查看是否有“ALM-14000 HDFS服务不可用”告警产生。

    • 是,执行10
    • 否,执行12

  2. 参考ALM-14000 HDFS服务不可用告警帮助指导处理该告警。
  3. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行12

检查Yarn服务状态。

  1. 在告警列表中,查看是否有“ALM-18000 Yarn服务不可用”告警产生。

    • 是,执行13
    • 否,执行15

  2. 参考ALM-18000 Yarn服务不可用告警帮助指导处理该告警。
  3. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行15

检查DBService服务状态。

  1. 在告警列表中,查看是否有“ALM-27001 DBService服务不可用”告警产生。

    • 是,执行16
    • 否,执行20

  2. 参考ALM-27001 DBService服务不可用告警帮助指导处理该告警。
  3. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行20

检查Hive服务状态。

  1. 在告警列表中,查看是否有“ALM-16004 Hive服务不可用”告警产生。

    • 是,执行19
    • 否,执行20

  2. 参考ALM-16004 Hive服务不可用告警帮助指导处理该告警。
  3. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行20

检查HetuEngine是否缺少HSBroker实例。

  1. 在FusionInsight Manager首页,选择“集群 > 待操作的集群名称 > 服务 > HetuEngine > 实例”。
  2. 查看是否缺少HSBroker实例。

    • 是,单击“添加实例”,添加缺少的实例。
    • 否,执行23

  3. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行23

检查HetuEngine与ZooKeeper、HDFS、Yarn、DBService、Hive之间的网络连接。

  1. 在FusionInsight Manager首页,选择“集群 > 待操作的集群名称 > 服务 > HetuEngine > 实例”。
  2. 单击“HSBroker”行的“主机名称”,记录“基本信息”下的“管理IP”的地址。
  3. omm用户通过25获取的IP地址登录HSBroker所在的主机。
  1. 执行ping命令,查看HSBroker所在主机与ZooKeeper、HDFS、Yarn、DBService、Hive服务所在主机的网络连接是否正常。

    • 是,执行30
    • 否,执行28

  2. 联系网络管理员恢复网络。
  3. 在告警列表中,查看“ALM-45000 HetuEngine服务不可用”告警是否清除。

    • 是,处理完毕。
    • 否,执行30

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选操作集群的“HetuEngine”,单击“确定”。
  3. 在“主机”中勾选对应角色所在的主机,单击“确定”。
  4. 单击右上角的,设置日志收集的“开始时间”和“结束时间”,分别为告警产生时间的前后30分钟,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。