更新时间:2025-08-09 GMT+08:00
        
          
          
        
      
      
      
      
      
      
      
      
  
      
      
      
        
ALM-18000 Yarn服务不可用
告警解释
告警模块按60秒周期检测Yarn服务状态。当检测到Yarn服务不可用时产生该告警。
Yarn服务状态恢复正常时,告警恢复。
告警属性
| 
         告警ID  | 
       
         告警级别  | 
       
         是否自动清除  | 
      
|---|---|---|
| 
         18000  | 
       
         紧急  | 
       
         是  | 
      
告警参数
| 
         参数名称  | 
       
         参数含义  | 
      
|---|---|
| 
         来源  | 
       
         产生告警的集群名称。  | 
      
| 
         服务名  | 
       
         产生告警的服务名称。  | 
      
| 
         角色名  | 
       
         产生告警的角色名称。  | 
      
| 
         主机名  | 
       
         产生告警的主机名。  | 
      
对系统的影响
- 集群无法提供Yarn服务。
 - 用户无法执行新的application。
 - 已提交的application无法执行。
 
可能原因
- ZooKeeper服务异常。
 - HDFS服务异常。
 - Yarn集群中没有主ResourceManager实例。
 - Yarn集群中的所有NodeManager节点异常。
 
处理步骤
检查ZooKeeper服务状态。
- 在FusionInsight Manager的告警列表中,查看是否有告警“ALM-13000 ZooKeeper服务不可用”产生。
 - 参考ALM-13000 ZooKeeper服务不可用的处理步骤处理故障后,检查本告警是否恢复。
     
     
- 是,处理完毕。
 - 否,执行步骤 3。
 
 
检查HDFS服务状态。
- 在FusionInsight Manager的告警列表中,查看是否有HDFS相关告警产生。
 - 选择“运维 > 告警 > 告警”,根据告警帮助处理HDFS相关告警后,检查本告警是否恢复。
     
     
- 是,处理完毕。
 - 否,执行步骤 5。
 
 
检查Yarn集群中的ResourceManager状态。
检查Yarn集群中的NodeManager节点状态。
- 在FusionInsight Manager界面,选择“集群 > 服务 > Yarn > 实例”。
 - 查看NodeManager的“运行状态”,检查是否有处于非良好状态的节点。
 - 按“ALM-18002 NodeManager心跳丢失”或“ALM-18003 NodeManager不健康”提供的步骤处理该故障,故障修复后检查本告警是否恢复。
     
     
- 是,处理完毕。
 - 否,执行步骤 10。
 
 
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
无。
    
      