1078919266 Remaining GaussDB(DWS) Database Disk Capacity Is Severely Insufficient
Alarm Description
This alarm is cleared when the disk or inode usage of a cluster instance is greater than or equal to 95%. This alarm is cleared when the disk or inode usage of the cluster instance is lower than 95%.
Alarm Attributes
Alarm ID |
Alarm Category |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|---|
1078919266 |
Tenant plane |
Critical |
Operation alarm |
DWS instance |
Yes |
Alarm Parameters

The number of parameters varies according to alarms.
Type |
Parameter |
Description |
---|---|---|
Location Info |
instance_id |
ID of the instance for which the alarm is generated |
instance_name |
Name of the instance that reports the alarm |
|
domain_name |
Domain name for which the alarm is generated |
|
domain_id |
Domain ID for which the alarm is generated |
|
datastore_type |
Type of the data storage for which the alarm is generated |
|
instance_role |
Role of the instance for which the alarm is generated |
|
component_instance_name |
Name of the component instance that reports the alarm, for example, cn_5001. |
|
Other Information |
CloudService |
Name of the cloud service for which the alarm is generated |
resourceId |
Resource ID for which the alarm is generated |
|
resourceIdName |
Resource for which the alarm is generated |
|
domain_name |
Domain name for which the alarm is generated |
|
domain_id |
Domain ID for which the alarm is generated |
Impact on the System
If the data disk or inode usage reaches 95%, the primary DN where the disk resides is restarted, and the standby and secondary DNs are forcibly stopped. If the log disk usage reaches 95%, DNs are not affected.
System Actions
None
Possible Causes
The cluster disk or inode usage exceeds 95%. As a result, the cluster becomes read-only and data cannot be written to or modified in the cluster.
Procedure
- Stop writing tasks immediately when the cluster is in the read-only state to prevent data loss caused by full disk space.
- Log in to the DWS console and cancel the read-only state of the cluster. For details, see Removing the Read-only Status.
- Log in to the DWS console.
- In the navigation pane on the left, choose Dedicated Clusters > Clusters. All clusters are displayed by default.
- In the Operation column of the target cluster, choose .
- In the dialog box that is displayed, click Yes to confirm and remove the read-only status for the cluster.
- After the read-only state is canceled, run the Vacuum command to delete unnecessary data. Click the cluster name.
- In the navigation pane, choose Intelligent O&M.
- Click the O&M Plan tab. Click Add O&M Task. For details, see Adding an O&M Plan.
- Perform the following operations on the Add O&M Task page:
- Select Vacuum for O&M Task.
- Set Scheduling Mode to Auto. GaussDB(DWS) automatically scans tables that require VACUUM operation.
- Select System catalogs or User tables for Autovacuum.
- If there are a large number of UPDATE and DELETE operations, select the User tables.
- If there are a large number of CREATE and DELETE operations, select System catalogs.
- Click Next: Configure Schedule to configure the schedule and Vacuum type. You are advised to select Periodic for Task Type. The GaussDB(DWS) automatically executes VACUUM in your selected time windows.
For automatic Vacuum O&M tasks, the system uses the VACUUM FULL operation to process user tables. VACUUM FULL holds a level 8 lock, which blocks other transactions. Other transactions will be in lock waiting during VACUUM FULL execution. After 20 minutes, a timeout error is reported. Therefore, do not perform other transactions in the configured time window.
- After confirming that the information is correct, click Next to complete the configuration.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
N/A
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot