ALM-12028 主机D状态进程数超过阈值(2.x及以前版本)
告警解释
系统每30秒周期性检测主机中omm用户D状态进程数,并把实际进程数和阈值相比较。主机D状态进程数默认提供一个阈值。当检测到进程数超出阈值时产生该告警。
当主机中omm用户D状态进程数小于或等于阈值时,告警恢复。
告警属性
告警ID |
告警级别 |
可自动清除 |
---|---|---|
12028 |
严重 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
ServiceName |
产生告警的服务名称。 |
RoleName |
产生告警的角色名称。 |
HostName |
产生告警的主机名。 |
Trigger Condition |
系统当前指标取值满足自定义的告警设置条件。 |
对系统的影响
占用系统资源,业务进程响应变慢。
可能原因
主机中正在等待的IO(磁盘IO、网络IO等)在较长时间内未得到响应,进程处于D状态。
处理步骤
- 查看D状态进程。
- 打开MRS集群详情页面,在告警列表中,单击此告警所在行,在告警详情中,查看该告警的主机地址。
- 登录告警节点。
- 执行以下命令切换用户:
su - omm
- 执行如下命令查看omm用户D状态进程号。
ps -elf | grep -v "\[thread_checkio\]" | awk 'NR!=1 {print $2, $3, $4}' | grep omm | awk -F' ' '{print $1, $3}' | grep D | awk '{print $2}'
- 查看D状态进程查询结果是否为空。
- 切换到root用户,执行reboot命令,重启产生告警主机。
重启主机有风险,请确保重启后业务进程正常。
- 等待5分钟,检查该告警是否恢复。
- 是,处理完毕。
- 否,执行2。
- 收集故障信息。
- 在MRS Manager界面,单击“系统设置 > 日志导出”。
- 请联系运维人员,并发送已收集的故障日志信息。
参考信息
无。