ALM-50843 Worker节点通讯异常告警
告警解释
系统按10分钟周期性检测实例Worker网络消息发送失败的次数,当检测到数量超过阈值后产生该告警。
当检测到实例Worker网络消息发送失败次数在阈值内时告警恢复。
告警属性
|
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
|---|---|---|---|---|
|
50843 |
次要 |
业务质量告警 |
MemArtsStore |
是 |
告警参数
|
参数名称 |
参数含义 |
|---|---|
|
来源 |
产生告警的集群或系统名称 |
|
服务名 |
产生告警的服务名称 |
|
角色名 |
产生告警的角色名称 |
|
主机名 |
产生告警的主机名 |
对系统的影响
节点网络不可用,导致业务出现失败。
可能原因
- 节点负载过大,导致网络消息超时,消息发送失败。
- 节点未正确与其他节点建链,导致消息发送失败。
处理步骤
判断网络错误类型
- 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”,查看“告警ID”为“50843”的“定位信息”中的角色名并确定实例的IP地址。
- 等待2分钟,查看告警是否自动恢复。
- 是,网络自愈,处理完毕。
- 否,执行步骤 3。
- 选择“集群 > 服务 > MemArtsStore > 实例”,单击告警上报的StoreWorker实例,进入实例“图表”页面,在左侧图标分类选择Pool操作。
- 观察“StoreWorker Pool操作mplog的平均延迟”是否大于1秒。
降低业务负载
- 降低业务端负载。
- 等待2分钟,查看告警是否自动恢复。
- 是,处理完毕。
- 否,执行步骤 7。
收集故障信息
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。