更新时间:2025-12-11 GMT+08:00
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ALM-50835 MemArtsStore健康检查不通过

告警解释

系统每30秒周期性检测进程状态、端口状态及sidecar与worker之间grpc通信状态,当检测到状态异常时,健康检查不通过,产生该告警。

状态异常清除且健康检查通过时,告警清除。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

50835

次要

业务质量告警

MemArtsStore

告警参数

参数名称

参数含义

来源

产生告警的集群或系统名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

对系统的影响

服务无法正常访问。

可能原因

  • 进程不存在。
  • 进程状态异常。
  • 端口检查异常。
  • sidecar和worker之间的grpc通信失败。

处理步骤

检查MemArtsStore进程状态

  1. FusionInsight Manager首页,选择“集群 > 服务 > MemArtsStore > 实例”。
  2. 选中运行状态不为良好的实例,选择“更多 > 重启实例”。
  3. 查看实例重启后运行状态是否为良好。

  4. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行步骤 5

检查端口状态或sidecar和worker之间通信状态

  1. 登录MemArtsStore服务异常的实例主机节点。
  2. 进入MemArtsStore的配置文件目录。

    cd /opt/Bigdata/FusionInsight_MemArtsStore_8.1.2.1/1_25_StoreWorker/etc

  3. 查看配置文件“worker.json”,找到告警附加信息提到的端口号。
  4. 查看端口占用情况。

    lsof -i:端口号

    解决端口占用问题。

  5. 在FusionInsight Manager首页,选择“集群 > 服务 > MemArtsStore > 实例”。
  6. 选中运行状态不为良好的实例,选择“更多 > 重启实例”。
  7. 查看实例重启后运行状态是否为良好。

  8. 在“运维 > 告警 > 告警”页签,查看该告警是否恢复。

    • 是,处理完毕。
    • 否,执行步骤 13

收集故障信息

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“MemArtsStore”。
  3. 单击右上角的编辑按钮设置日志收集的“开始时间”和“结束时间”,分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

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