更新时间:2024-09-23 GMT+08:00
分享

ALM-45596 Procedure执行失败

告警解释

Procedure是由ConfigNode Leader管理执行的任务,如果有Procedure执行失败,则会产生此告警。如果同一个Procedure重新执行成功,告警清除。

告警属性

告警ID

告警级别

是否可自动清除

45596

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名称。

Procedure信息

Procedure相关信息。

对系统的影响

Procedure任务执行失败,会影响任务操作一致性。

可能原因

  • IoTDB副本补齐任务运行失败。
  • 删除存储组任务运行失败。

处理步骤

  1. 在FusionInsight Manager页面,选择“运维 > 告警 > 告警”,单击“Procedure执行失败”告警前面的
  2. 查看“定位信息”中“Porcedure信息”的值, 该值以Procedure类型开头,包括Procedure相关的主要信息。

查看副本补齐任务运行是否失败

  1. “Porcedure信息”的值是否以“AddRegionProcedure”或者“ReJoinDataNodeProcedure”开头。

    • 是,表示副本补齐运行失败,执行4
    • 否,执行5

  2. 等待半小时,如果该Region再次补齐成功该告警会自动清除,否则执行5

查看删除存储组任务运行是否失败。

  1. “Porcedure信息”的值是否以“DeleteStorageGroupProcedure”开头。

    • 是,表示删除存储组失败,执行6
    • 否,执行7

  2. 重新尝试在IoTDB客户端删除“Porcedure信息”中显示的存储组,删除成功该告警将自动清除,否则执行7

收集故障信息。

  1. 选择“集群 > 服务 > IoTDB > 实例”,查看所有IoTDBServer实例和ConfigNode实例所在的主机。
  2. 选择“运维 > 日志 > 下载”。
  3. 在“服务”中勾选操作集群的“IoTDB”,单击“确定”。
  4. 在“主机”勾选7查看到的主机,单击“确定”。
  5. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后30分钟,单击“下载”。
  6. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

相关文档