更新时间:2024-11-22 GMT+08:00
分享

ALM-38017 分区均衡时间超过阈值

告警解释

系统每10分钟(可以通过修改Kafka配置项“auto.reassign.check.interval.ms”调整)周期性检测,扩容新的Broker后触发的分区均衡时间超过阈值(默认为1440分钟,可以通过修改Kafka配置项“reassignment.total.time.threshold”调整)时上报告警。

当分区均衡完成后,告警清除。

该告警仅适用于MRS 3.5.0及之后版本。

告警属性

告警ID

告警级别

是否可自动清除

38017

重要

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的集群内服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

Trigger Condition

系统当前指标取值满足自定义的告警设置条件。

对系统的影响

Broker实例扩容后长时间未完成分区均衡操作,导致Kafka服务长时间处于分区不均衡状态,可能会影响业务读写流量性能降低。

可能原因

迁移的分区数据量过大,限流参数设置的太小。

处理步骤

  1. 登录KafkaUI页面。

    1. 使用具有KafkaUI页面访问权限的用户,登录FusionInsight Manager。
    2. 选择“集群 > 服务 > Kafka”。
    3. 在“KafkaManager WebUI”右侧,单击URL链接,访问KafkaUI的页面。

  2. 单击“Current Reassign Status”查看当前进行的分区均衡任务。

  3. 观察正在迁移的分区的状态,如果进度长时间无变化,单击“Modify Reassignment Throttle”查看限流参数是否过小。

    • 是,在业务空闲时间调整“Throttle”参数,单击“OK”,加快迁移速度。执行4
    • 否,执行5

  4. 等待10分钟,查看分区迁移进度是否有明显变化。

    • 是,操作结束。
    • 否,执行5

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”框中勾选待操作集群的“Kafka”。
  3. 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

相关文档