ALM-24015 Flume MonitorServer证书文件已过期
本章节适用于MRS 3.2.0及以后版本。
告警解释
MonitorServer每隔一个小时健康检查时,检查当前系统中的证书文件是否已过期。如果服务端证书已过期,产生该告警。服务端证书恢复的有效期内,告警恢复。
告警属性
告警ID |
告警级别 |
是否自动清除 |
---|---|---|
24015 |
重要 |
是 |
告警参数
参数名称 |
参数含义 |
---|---|
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
角色名 |
产生告警的角色名称。 |
主机名 |
产生告警的主机名。 |
对系统的影响
MonitorServer证书文件已过期,功能受限,Flume客户端将无法访问Flume服务端。
可能原因
MonitorServer证书文件已过期。
处理步骤
查看告警信息。
- 登录FusionInsight Manager首页,选择“运维 > 告警 > 告警 > ALM-24015 MonitorServer证书文件已过期 > 定位信息”。查看告警上报的实例的IP地址。
检查系统中合法证书文件的有效期,重新生成证书文件。
- 以root用户登录告警所在节点主机,并执行su - omm切换用户。
- 执行以下命令进入MonitorServer证书目录。
cd ${BIGDATA_HOME}/FusionInsight_Porter_*/install/FusionInsight-Flume-*/flume/conf
- 执行以下命令查看用户证书的生效时间与失效时间,查看目前时间是否在有效期内。
- 执行以下命令进入Flume脚本目录。
cd ${BIGDATA_HOME}/FusionInsight_Porter_*/install/FusionInsight-Flume-*/flume/bin
- 执行以下命令重新生成证书,等待1小时,观察此告警是否被清除。
- 使用omm用户在Flume实例产生告警的节点,重复执行5~6,等待1小时,观察此告警是否被清除。
- 查看系统在定时检查时是否会再次产生此告警。
- 是,执行9。
- 否,处理完毕。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
无。