更新时间:2024-11-22 GMT+08:00
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ALM-16047 HiveServer已从Zookeeper注销

告警解释

系统每60秒周期性检测Hive服务,若Hive在Zookeeper上的注册信息丢失,或者Hive无法连接上Zookeeper,将会发出告警。

告警属性

告警ID

告警级别

是否自动清除

16047

重要

告警参数

参数名称

参数含义

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

Hive客户端新建连接时,无法选取已从Zookeeper注销的HiveServer节点。若所有HiveServer均已从Zookeeper注销,将导致HiveServer服务不可用。

可能原因

  • ZooKeeper实例状态异常。
  • Hive相关配置修改错误。

处理步骤

检查ZooKeeper服务状态。

  1. 在FusionInsight Manager界面,选择“运维 > 告警 > 告警”,在告警列表中查看是否有“ALM-12007 进程故障”告警产生。

    • 是,执行2
    • 否,执行5

  2. 在“ALM-12007 进程故障”的“定位信息”中查看“服务名”是否为“ZooKeeper”。

    • 是,执行3
    • 否,执行5

  3. 参考ALM-12007 进程故障的处理步骤处理该故障。
  4. 在告警列表中,查看“ALM-16047 HiveServer已从Zookeeper注销”告警是否清除。

    • 是,处理完毕。
    • 否,执行5

检查Hive相关配置修改是否正确。

  1. 在FusionInsight Manager界面,单击“审计”,在审计页面单击“高级搜索”,单击“操作类型”右侧的,选择“保存配置 > 确定”,再单击“搜索”。
  2. 查看搜索结果中“服务”列为与Hive、ZooKeeper相关的服务,检查近期修改的配置,表1为部分可能影响Hive连接ZooKeeper的配置。

    表1 Hive连接ZooKeeper的相关配置

    服务

    参数名称

    参数说明

    Hive

    HIVE_GC_OPTS

    HiveServer内存配置,异常配置可能导致HiveServer反复重启,需要排查实例进程健康状况。

    hive.zookeeper.quorum

    Hive连接的ZooKeeper所在节点IP地址。

    hive.zookeeper.client.port

    Hive连接的ZooKeeper客户端端口。

    hive.zookeeper.session.timeout

    Hive连接ZooKeeper会话超时时间。

    hive.zookeeper.connection.timeout

    Hive尝试连接ZooKeeper的超时时间。

    hive.zookeeper.connection.max.retries

    Hive尝试连接ZooKeeper的最大重试次数。

    ZooKeeper

    clientPort

    ZooKeeper的客户端端口。

    ssl.enabled

    ZooKeeper的SSL连接开关。

重启相关实例

  1. 登录FusionInsight Manager,在FusionInsight Manager首页,选择“运维 > 告警 > 告警”,单击告警“HiveServer已从Zookeeper注销”所在行的下拉菜单,在“定位信息”中查看告警上报的角色名并确定实例IP地址。
  2. 选择“集群 > 待操作集群的名称 > 服务 > Hive > 实例”,勾选上报告警IP对应的实例,选择“更多 > 重启实例”。

    正在重启的Hive实例无法对外提供服务,该实例上正在执行的SQL任务可能失败。

  3. 重启完成后,等待5分钟,查看告警是否消除。

    • 是,处理完毕。
    • 否,执行10

收集故障信息。

  1. 在FusionInsight Manager首页,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“Hive”。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

无。

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