更新时间:2025-12-11 GMT+08:00
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ALM-12217 集群用户冲突

告警解释

系统每2小时周期性检测MRS Manager用户和操作系统用户是否存在冲突情况,当集群中创建的Manager用户和节点上的系统用户产生冲突时,上报告警。

当下一个检测周期检测不存在冲突用户时告警恢复。

该告警仅适用于MRS 3.6.0及之后版本。

告警属性

告警ID

告警级别

是否可自动清除

12217

重要

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

详细信息

产生告警的详细信息。

对系统的影响

  • 可能导致组件业务鉴权失败,进而影响服务及进程状态。
  • 可能导致组件作业提交失败或者作业运行异常。

可能原因

Manager上创建的用户与操作系统用户同名。

处理步骤

检查是否存在冲突用户。

  1. 登录MRS Manager页面,选择“运维 > 告警 > 告警”,查看当前告警详情,在定位信息中查看发生该告警的主机名称。单击主机名称,查看对应的IP地址。
  2. omm用户登录告警所在主机IP节点。
  3. 执行以下命令,获取到当前主机上创建的操作系统用户,并确认查询的结果中是否存在与集群上同名的Manager用户。

    cut -d: -f1 /etc/passwd

  4. 当前集群存在与Manager同名的用户,请根据告警附加信息中的用户列表,分析并确认删除操作系统用户或Manager用户。

    附加信息中多个冲突用户之间使用空格进行分隔。

  5. 处理完冲突用户之后等待下一个检查周期,观察告警是否清除。

    • 是,处理完毕。
    • 否,执行步骤 6

收集故障信息。

  1. 在MRS Manager页面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选“OmmServer”和“NodeAgent”。主机选择告警定位信息中的主机名称。
  3. 单击右上角的编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。

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