更新时间:2022-05-19 GMT+08:00
分享

版本是否符合从低到高或者同版本迁移

MySQL迁移场景

表1 版本是否符合从低到高或者同版本迁移

预检查项

版本是否符合从低到高或者同版本迁移。

描述

检查用户使用的版本是否低于或等于目标端数据库版本。

不通过提示处理建议

不通过原因:源数据库连接失败,导致该项检查无法进行。

处理建议:查看源数据库连接是否成功。

不通过原因:目标数据库连接失败,导致该项检查无法进行。

处理建议:查看目标数据库连接是否成功。

不通过原因:源数据库版本不支持。

处理建议:查看源数据库版本是否符合迁移要求,目前源数据库版本支持MySQL 5.5.x、MySQL 5.6.x、MySQL 5.7.x和MySQL 8.0.x。

不通过原因:目标数据库版本不支持。

处理建议:查看目标数据库版本是否符合迁移要求,目前目标数据库版本支持MySQL 5.6.x、MySQL 5.7.x和MySQL 8.0.x。

不通过原因:内部错误。

处理建议:请联系华为技术支持人员处理。

不通过原因:用户基本权限不足。

处理建议:查看对应数据库账号权限是否符合迁移要求。

不通过原因:目前不支持从高版本数据库到低版本数据库的迁移或同步。

处理建议:采用合适版本的数据库。

PostgreSQL同步场景

表2 版本是否符合从低到高或者同版本迁移

预检查项

版本是否符合从低到高或者同版本迁移。

描述

检查用户使用的版本是否低于或等于目标端数据库版本。

不通过提示处理建议

不通过原因:源数据库连接失败,导致该项检查无法进行

处理建议:查看源数据库连接是否成功。

不通过原因:目标数据库连接失败,导致该项检查无法进行。

处理建议:查看目标数据库连接是否成功。

不通过原因:用户基本权限不足。

处理建议:查看对应的数据库账号权限是否符合迁移要求。

不通过原因:源数据库版本不支持。

处理建议:查看源数据库版本是否符合迁移要求,目前只支持大版本PostgreSQL 9.4、PostgreSQL 9.5、PostgreSQL 9.6、PostgreSQL 10.0、PostgreSQL 11.0、PostgreSQL 12.0、PostgreSQL 13.0和PostgreSQL增强版。

不通过原因:目标数据库版本不支持。

处理建议:查看目标数据库版本是否符合迁移要求,目前只支持大版本PostgreSQL 9.5、PostgreSQL 9.6、PostgreSQL 10.0、PostgreSQL 11.0、PostgreSQL 12.0、PostgreSQL 13.0和PostgreSQL增强版。

不通过原因:目前只支持源数据库和目标数据库的大版本相等并且源库小版本号必须小于等于目标数据库的小版本号。

处理建议:采用合适版本的数据库。

不通过原因:源数据库为RDS for PostgreSQL增强版时,目标数据库仅支持RDS for PostgreSQL增强版。

处理建议:目标数据库选择RDS for PostgreSQL增强版。

不通过原因:内部错误。

处理建议:请联系华为技术支持人员处理。

不通过原因:目标数据库和源数据库版本不满足当前所选择迁移模式的要求。

处理建议:请查看目标数据库和源数据库的版本是否符合迁移模式的要求。

MySQL灾备场景

表3 版本是否符合从低到高或者同版本迁移

预检查项

版本是否符合从低到高或者同版本迁移。

描述

检查用户使用的版本是否低于或等于目标端数据库版本。

不通过提示处理建议

不通过原因:源数据库和目标数据库的版本不一致或者不符合版本要求。

处理建议:源数据库和目标数据库版本要求一致,且都是5.6、5.7、8.0,请更换符合要求的数据库版本。

MongoDB迁移场景

表4 源数据库版本是否支持

预检查项

版本是否符合从低到高或者同版本迁移。

描述

检查用户使用的版本是否低于或等于目标端数据库版本。目标库支持最高版本为4.0.x,当源库版本高于目标库时,不符合从低到高或者同版本迁移。此时需确认源库业务中是否有用到高版本提供的新特性,目标库无此特性会有同步失败的风险。

不通过提示处理建议

待确认原因:源数据库和目标数据库的版本不同。

潜在问题:源库版本为4.4.5,目标库版本为4.0.3,不符合从低到高或者同版本迁移。如果源库业务中有用到高版本提供的新特性而目标库无此特性,会有同步失败的风险。

不通过原因:目标数据库版本不满足要求。

处理建议:源库版本高于4.0.x,而目标库是3.4.x,目标库请选择4.0.x版本。

分享:

    相关文档

    相关产品

close