更新时间:2024-12-03 GMT+08:00
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云AP上线失败

现象描述

华为乾坤云平台上,云AP的“设备状态”为“未注册”。

可能的原因

  • 华为乾坤云平台录入的设备ESN和设备款型与实际不一致。
  • AP设备与注册查询中心或者华为乾坤云平台网络不通。
  • 设备版本或者款型不支持在华为乾坤云平台上线。

处理步骤

  1. 检查华为乾坤云平台侧录入的设备ESN和设备款型与实际是否一致。

    1. 以租户帐号登录华为乾坤控制台
    2. 单击“资源中心 > 设备管理”,查看AP设备的ESN和设备款型。

      • 如果ESN不一致,请单击“操作”列的进行修改。
      • 如果设备型号不一致,请单击“操作”列的删除然后再重新添加。
      图1 设备管理

  2. 登录AP设备,做进一步检查。

    如何登录:如果知道IP地址,可以直接登录分配的IP地址。如果不知道IP地址,可以用手机或者电脑连接AP的管理SSID (hw_manager_xxx),登录设备的管理面(169.254.2.1),查看设备信息。登录Web后,如果AP的工作模式不是“云模式”,请手动切换为“云模式”再登录。

  3. 执行命令display cloud-mng info,检查AP设备的华为乾坤云平台配置信息。

    <HUAWEI> system-view
    [HUAWEI] diagnose
    [HUAWEI-diagnose] display cloud-mng info
    ------------------------------------------------------------
    
     AP status                :  Online
    
    ------------------------------------------------------------
    
     Controller address
       Controller
         Controller URL           :  -
         Controller IP address    :  -
         Controller port          :  -
       DHCP(active)
         Controller URL           :  device.qiankun-saas.huawei.com
         Controller IP address    :  -
         Controller port          :  10020
       Configuration
         Controller URL           :  -
         Controller IP address    :  -
         Controller port          :  -
       Register Center
         Controller URL           :  -
         Controller IP address    :  139.9.137.139
         Controller port          :  10020
       Default
         Controller URL           :  -
         Controller IP address    :  -
         Controller port          :  -
    
    ------------------------------------------------------------

  4. 执行ping device.qiankun-saas.huawei.com,检查AP设备与华为乾坤云平台的网络是否可以正常通信。

    如果无法ping通,则请继续ping 139.9.137.139。

    • 如果依然ping不通,则表示网络不通,请检查客户网络,是否由防火墙等安全设备进行了拦截。
    • 如果能ping通,则表示未配置DNS或者配置的DNS不正确,请检查DNS的配置。
    <HUAWEI> ping device.qiankun-saas.huawei.com
      PING device.qiankun-saas.huawei.com (139.9.137.139): 56  data bytes, press CTRL_C to break
        Reply from 139.9.137.139: bytes=56 Sequence=1 ttl=52 time=35 ms
        Reply from 139.9.137.139: bytes=56 Sequence=2 ttl=52 time=34 ms
        Reply from 139.9.137.139: bytes=56 Sequence=3 ttl=52 time=35 ms
        Reply from 139.9.137.139: bytes=56 Sequence=4 ttl=52 time=34 ms
        Reply from 139.9.137.139: bytes=56 Sequence=5 ttl=52 time=34 ms
    
      --- device.qiankun-saas.huawei.com ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 34/34/35 ms

  5. 执行命令display cloud-mng offline-record查看云AP最近10次下线记录信息。

    <HUAWEI> system-view
    [HUAWEI] diagnose
    [HUAWEI-diagnose] display cloud-mng offline-record
    The MPU frame[0] board[0]'s reset and offline total 9, detailed information:
    --  1. 2023-10-25   16:08:17,  No.: 9
           Reason: Connection lost
    --  2. 2023-10-25   15:11:23,  No.: 8
           Reason: Connection lost
    --  3. 2023-10-24   16:20:14,  No.: 7
           Reason: Reset for AP self-healing (The time during which the AP is offline exceeds the specified timeout period for an AP reset triggered by self-healing)
    --  4. 2023-10-23   16:18:10,  No.: 6
           Reason: Connection lost
    --  5. 2023-10-23   13:56:15,  No.: 5
           Reason: Connection lost
    --  6. 2023-10-23   13:15:04,  No.: 4
           Reason: Connection lost
    --  7. 2023-10-23   12:25:28,  No.: 3
           Reason: Connection lost
    --  8. 2023-10-23   11:52:24,  No.: 2
           Reason: Connection lost
    --  9. 2023-10-23   11:35:15,  No.: 1
           Reason: Connection lost
    表1 常见重启原因

    常见设备重启原因

    解释

    处理建议

    Reset for others

    其他原因复位。

    联系技术支持

    System initialized and reset all

    系统初始化,复位所有单板。

    无需处理。

    Reset by user command

    命令行复位。

    无需处理。

    VRP reset selfboard because of command

    VRP命令行复位本板。

    无需处理。

    VRP reset selfboard because of Unexpected State

    VRP出现不可预期的状态。

    联系技术支持

    VRP reset selfboard because of no memory

    VRP发现主控板内存不足。

    检查内存占用情况。

    VRP reset selfboard because slave didn't finish Batch

    批量备份没有结束,主控板没有响应。

    联系技术支持

    Reset selfboard because of find deadloop

    VRP监控到死循环。

    联系技术支持

    Reset selfboard because of find exception

    VRP监控到异常。

    联系技术支持

    Reset for memory use out

    内存耗尽。

    检查内存占用情况。

    Reset for CPLD self-test fail

    CPLD自检失败。

    检查CPLD自检失败原因。

    Cold reset board for CPU is not active

    单板CPU没有启动,冷复位单板。

    联系技术支持

    Reset slave board for memsize too little

    备板内存太小,复位单板。

    检查内存占用情况。

    Reset for cfcard storage exception

    CF card发生异常复位。

    联系技术支持

    Reset for board workmode switch succeed

    单板工作模式切换成功。

    无需处理。

    Reset for power off

    掉电重启。

    无需处理。

    Reset for kernel panic

    内核kp重启。

    联系技术支持

    Reset for switch zone after update version

    AP升级主备区切换重启。

    无需处理。

    Reset for update version success

    AP升级成功后重启。

    无需处理。

    Reset for update version failed

    AP升级失败重启。

    检查AP升级失败原因。

    Reset for exception

    vos异常信号重启。

    联系技术支持

    Reset for watchdog

    看门狗异常重启。

    联系技术支持

    Reset for cpld

    写cpld寄存器复位。

    联系技术支持

    Reset for reset-key

    按键复位。

    无需处理。

    Reset for ap disturbed

    AP靠太近干扰复位。

    增大AP之间的距离。

    Reset for 11ac target chip abnormal

    WIFI固件异常重启。

    联系技术支持

    Reset for tx dma stop

    tx dma 停止。

    联系技术支持

    Reset for restoration to factory defaults(by command)

    恢复出厂配置。

    无需处理。

    Reset for MFPI detect MSC module abnormal

    MFPI监控到MSC模块异常重启。

    联系技术支持

    Reset for MFPI detect MSU module abnormal

    MFPI监控到MSU模块异常重启。

    联系技术支持

    Reset for an AP upgrade

    AP升级。

    无需处理。

    Reset for restoration to factory defaults

    恢复出厂设置。

    无需处理。

    Reset for an AP management VLAN change

    AP的管理VLAN的变更。

    无需处理。

    Reset for a country code mismatch

    不支持的国家码。

    检查国家码配置。

    Reset for AP deleted by controller

    AP被控制器删除。

    无需处理。

    Reset for abnormal network port self-healing

    网口异常自愈。

    检查网口。

    Reset for the forcible AP disconnection in specific scenarios

    特定场景下强制AP断开。

    联系技术支持

    Reset for a channel set switching

    室外款AP支持加载室内国家码信道集的配置。

    无需处理。

    Reset for slow task switching

    系统运行慢导致的重启。

    检查内存占用情况。

    Reset for restoration to factory defaults(by button)

    恢复出厂配置。

    无需处理。

    Reset for MFPI detect CAP PBUF use out

    MFPI监控到转发PBUF耗尽重启。

    联系技术支持

    Reset for ap abnormal self-healing

    WIFI驱动侧收发包长时间异常后自愈重启。

    联系技术支持

    Reset for exception(redis-server exit)

    redis-server进程异常退出导致的重启。

    联系技术支持

    Reset for exception(confd exit)

    confd进程异常退出导致的重启。

    联系技术支持

    Reset for exception(callhome exit)

    callhome进程异常退出导致的重启。

    联系技术支持

    Reset for an abnormal process.

    进程异常。

    联系技术支持

    Reset for AP self-healing (The time during which the AP is offline exceeds the specified timeout period for an AP reset triggered by self-healing)

    AP离线的时间超过了用户配置的离线自愈重启时间阈值。

    检查AP上线失败原因。

    Reset for the version rollback because the AP does not go online after the online upgrade

    在线升级后AP未上线回退版本重启。

    检查AP上线失败原因。

    Reset for an NP heartbeat message exception

    NP心跳报文异常重启。

    无需处理。

    Reset for exception(dophi-server exit)

    dophi-server进程异常退出导致的重启。

    联系技术支持

    Reset for a Wi-Fi SDK self-healing failure

    Wi-Fi SDK自愈失败重启。

    联系技术支持

    Reset for a module exception

    NP模块产生异常重启。

    联系技术支持

    Reset for a heartbeat failure

    NP心跳故障重启。

    联系技术支持

    Reset for the number of soft or hard failures exceeding the threshold

    NP发生软失效或硬失效达到门限重启。

    联系技术支持

    Reset for isolation of more than half of atom threads

    NP atom线程隔离达到了一半以上重启。

    联系技术支持

    Reset for a fatal exception

    NP异常重启。

    联系技术支持

    Reset for the radio mode change

    射频模式切换重启。

    无需处理。

  6. 执行命令display cloud-mng online-fail-record查看AP最近5次上线失败记录信息。

    [HUAWEI] diagnose
    [HUAWEI-diagnose] display cloud-mng online-fail-record diagnostic-information
    ------------------------------------------------------------------
    --  1. 2023-10-25   23:15:07,  No.: 1
           Controller: device.qiankun-saas.huawei.com
           Reason: DNS failed
           Diagnostic-information:
    ......
    表2 上线失败原因

    上线失败原因

    解释

    处理建议

    AP can't obtain address

    设备无法获取IP

    请检查DHCP服务器,确保设备能获取IP地址。

    Connect to confd failed

    confd进程异常

    联系技术支持

    DNS failed

    设备无法通过DNS解析华为乾坤云平台地址

    请检查DNS服务器,确保设备能正确解析到华为乾坤云平台的IP地址。

    Connect to controller failed

    连接华为乾坤云平台失败

    请检查网络连通性和端口,确保设备能正常访问华为乾坤云平台的10020端口。

    Could not load host key

    证书加载失败

    联系技术支持

    Register Fail: Internal error, the controller is not already

    华为乾坤云平台未启动完成,或者正在获取当前部署场景

    联系技术支持

    Register Fail: Get the device's information timeout or the device returns fail

    华为乾坤云平台获取设备信息失败

    联系技术支持

    Register Fail: Illegal device's information format

    设备上报的信息格式有误

    联系技术支持

    Register Fail: The device is not added to the controller

    设备的ESN未添加到华为乾坤云平台

    请将设备的ESN添加到华为乾坤云平台的站点中。

    Register Fail: License is not authorized or expired

    License未授权或过期

    请确保华为乾坤云平台上的License资源充足(套餐正常)。

    Register Fail: Distribution controller node failure

    华为乾坤云平台节点分配失败

    联系技术支持

    Register Fail: The device unreports device models

    设备未向华为乾坤云平台上报款型信息

    联系技术支持

    Register Fail: The device model do not match with esn

    设备上报的款型信息和ESN不匹配

    联系技术支持

    Register Fail: The device unreports MAC

    设备未上报MAC或不符合MAC规则

    联系技术支持

    Register Fail: The cloud APs cannot add to AC site

    云AP不能加入到AC类型的站点

    请将设备添加到AP类型的站点。

    Register Fail: The ESN is not in allow rule

    设备不在白名单中

    联系技术支持

    Register Fail: Unsupport fail reason

    未知原因

    联系技术支持

  7. 参考《华为乾坤云管理网络配套款型表》(若无权限访问,请联系华为渠道获取),检查该设备是否在华为乾坤云平台配套的列表中。

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