Windows云服务器无法访问公网怎么办?
问题描述
从Windows云服务器访问外部网络,遇到网络不通的情形,即访问公网不通,可参考本节内容进行排查。
排查思路
以下排查思路根据原因的出现概率进行排序,建议您从高频率原因往低频率原因排查,从而帮助您快速找到问题的原因。
如果解决完某个可能原因仍未解决问题,请继续排查其他可能原因。
可能原因 |
处理措施 |
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资源状态异常:资源冻结;未开机;未绑定弹性公网IP。 |
云服务器状态为“运行中”,且绑定弹性公网IP才可以访问公网,详细操作请参考检查资源状态是否正常。 |
云服务器负载过高。 |
云服务器的带宽和CPU利用率过高导致网络断开,详细操作请参考检查云服务器负载是否过高。 |
弹性公网IP的带宽超限。 |
请扩大带宽后重试,详细操作请参考检查弹性公网IP的带宽是否超限。 |
互联网运营商的劫持或者封堵。 |
更换手机热点或其他网络测试是否可以正常访问,详细操作请参考检查是否为运营商网络问题。 |
网络配置错误。 |
检查网卡配置、DNS配置是否正确,详细操作请参考检查网卡配置。 |
路由信息配置错误。 |
查看活动路由中的0.0.0.0默认路由是否指向默认网关,详细操作请参考检查默认路由是否指向默认网关。 |
安全组配置不正确。 |
检查安全组是否放通出方向网络流量,详细操作请参考检查云服务器安全组。 |
检查网络ACL规则。 |
请取消关联的网络ACL后重试,详细操作请参考检查网络ACL规则。 |
国际链路问题。 |
请优化链路后重试,详细操作请参考检查是否为国际链路问题。 (适用于访问中国大陆外,包括中国港澳台及其他国家、地区的网站的场景) |
弹性公网IP被封堵。 |
IP若被封堵,则无法访问公网,详细操作请参考检查弹性公网IP是否被封堵。 |
防火墙拦截。 |
测试防火墙关闭后是否可以正常访问,详细操作请参考检查云服务器的防火墙。 |
网关通信异常。 |
使用Ping命令判断DNS服务器解析是否正常,详细操作请参考使用Ping命令检查网关通信是否正常。 |
云服务器系统性能问题。 |
使用netstat命令检查网络连接状态,详细操作请参考检查云服务器系统性能。 |
第三方杀毒软件的阻拦。 |
禁用或者卸载第三方杀毒软件后重试,详细操作请参考检查是否为杀毒软件拦截。 |
云服务器受病毒或木马影响。 |
判断云服务器是否受病毒或木马影响,详细操作请参考检查主机安全状态。 |
检查资源状态是否正常
- 请在控制台检查云服务器资源状态是否为“运行中”。
- 检查云服务器是否已绑定弹性公网IP。
绑定弹性公网IP才可以实现访问公网,请检查弹性云服务器是否绑定了弹性公网IP。
绑定弹性公网IP请参考绑定弹性公网IP。
检查云服务器负载是否过高
当云服务器出现网络断开的情况,则可能是云服务器的带宽和CPU利用率过高导致。
如果您已经通过云监控服务创建过告警任务,当CPU或带宽利用率高时,系统会自动发送告警给您。
Windows弹性云服务器带宽流量过高或CPU利用率高,请参考Windows云服务器卡顿怎么办?进行排查。
检查弹性公网IP的带宽是否超限
弹性云服务器绑定了弹性公网IP时,通过带宽提供公网和弹性云服务器间的访问流量。
如果出现访问公网不通,请排查弹性公网IP带宽是否超过带宽最大上限。
排查带宽超限的方法请参考如何排查带宽超过限制?
扩大带宽的操作请参考修改弹性公网IP的带宽。
检查是否为运营商网络问题
检查是否仅是访问特定地址有问题,如果是特定地址有问题,则可能跟运营商封堵阻拦有关。
尝试更换其他热点访问测试,如果网络环境正常,可能是本地运营商网络问题,建议联系运营商解决问题。
检查云服务器安全组
检查弹性云服务器安全组是否有配置错误,安全组出方向规则为白名单(允许),放通出方向网络流量。
例如图6所示,配置出方向允许所有访问。
可参考修改安全组规则配置,开放允许访问的协议或端口。
检查是否为国际链路问题
云服务器可能会出现访问中国大陆外(包括中国港澳台及其他国家、地区)网站不通或卡顿的问题。这是由于访问中国大陆外DNS服务器速度慢,导致的访问卡顿。
如果您有访问中国大陆外网站的需求,建议您购买中国大陆外的弹性云服务器。您可以在购买弹性云服务器时通过选择对应的中国大陆外区域来购买相应区域的弹性云服务器。
如果需优化国际链路的访问速度,请参考弹性云服务器访问中国大陆外网站时加载缓慢怎么办?
检查弹性公网IP是否被封堵
IP 封堵是指将所有流量指向 NULL。若被封堵,则无法访问公网。
一般情况下,客户被封堵的EIP,若无继续攻击,会在24小时后自动解封。
建议后期使用DDoS高防服务,防止再次被攻击。