Help Center/ Log Tank Service/ FAQs/ Log Search and Analysis/ What Do I Do If I Cannot View Reported Logs in LTS?
Updated on 2024-08-21 GMT+08:00

What Do I Do If I Cannot View Reported Logs in LTS?

Symptom

Logs reported to LTS are not displayed on the LTS console.

Possible Causes

  • ICAgent has not been installed.
  • The collection path is incorrectly configured.
  • ICAgent Collection in Configuration Center on the LTS console is disabled.
  • You set the log collection to be stopped when the free quota is used up on the LTS console.
  • Log collection was stopped because your account is in arrears.
  • The rate of writing logs into log streams or length of single-line logs exceeds what is supported.
  • The browser has slowed down because of the amount of log data.

Solution

  • If ICAgent has not been installed, install it. For details, see Installing ICAgent.
  • If the collection path is incorrectly configured, modify it. If the collection path is set to a directory, for example, /var/logs/, only .log, .trace, and .out files in the directory are collected. If the collection path is set to a text file name, that file is directly collected. For details about log collection paths, see Collecting Logs from Hosts.
  • If ICAgent Collection is disabled, log in to the LTS console, choose Configuration Center > ICAgent Collection, and enable ICAgent Collection.
  • Log usage, including log read/write, indexing, and storage, is billed in LTS. If you have disabled Continue to Collect Logs When the Free Quota Is Exceeded on the LTS console, log collection will be stopped when the free quota is used up. Log read/write and indexing will no longer be available. No fees will be incurred for log read/write and indexing. To resume log collection, enable Continue to Collect Logs When the Free Quota Is Exceeded on the LTS console. For details, see Configuration Center.
  • If log collection was stopped because your account is in arrears, top up your account. For details, see Making Repayments (Prepaid Direct Customers).
  • If the rate of writing logs into log streams or length of single-line logs exceeds the limit, or the browser has slowed down because of the amount of log data, use Google Chrome or Firefox to query logs.
  • If the issue persists after you have tried the methods above, submit a service ticket.