ALM-14000 Servicio HDFS no disponible (para MRS 2.x o anterior)
Descripción
El sistema comprueba el estado del servicio de NameService cada 30 segundos. Esta alarma se genera cuando el sistema considera que el servicio HDFS no está disponible porque todos los servicios NameService son anormales.
Esta alarma se borra cuando al menos un servicio NameService es normal y el sistema considera que el servicio HDFS se recupera.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
14000 |
Crítica |
Sí |
Parámetros
Parámetro |
Descripción |
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ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
HDFS no proporciona servicios para componentes de capa superior basados en servicios HDFS, como HBase y MapReduce. Como resultado, los usuarios no pueden leer ni escribir archivos.
Causas posibles
- ZooKeeper es anormal.
- Todos los servicios de NameService son anormales.
Procedimiento
- Compruebe el estado del ZooKeeper.
- Vaya a la página de detalles del clúster de MRS. En la página de la pestaña Components, compruebe si el estado del servicio ZooKeeper es Good.
- Rectificar el estado de salud del servicio ZooKeeper. Para obtener más información, consulte ALM-13000 El servicio ZooKeeper no está disponible (Para MRS 2.x o anterior). A continuación, compruebe si el estado de salud del servicio ZooKeeper es Good.
- Espere 5 minutos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 2.a.
- Maneje la alarma de excepción de servicio NameService.
- Vaya a la página de detalles del clúster de MRS. En la página Alarms, compruebe si todos los servicios de NameService tienen alarmas anormales.
- Maneje los servicios NameService anormales siguiendo las instrucciones en ALM-14010 NameService es anormal (Para MRS 2.x o anterior) y comprobar si cada alarma de excepción de servicio NameService está borrada.
- Espere 5 minutos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 3.
- Recopile información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Referencia
Ninguna