ALM-14001 El uso del disco de HDFS supera el umbral (Para MRS 2.x o anterior)
Descripción
El sistema comprueba el uso del disco del clúster HDFS cada 30 segundos y compara el uso real del disco con el umbral. El indicador de uso de disco de clúster HDFS tiene un umbral predeterminado. Esta alarma se genera cuando el uso del disco HDFS excede el umbral.
Esta alarma se borra cuando el uso del disco del clúster HDFS es menor o igual al umbral.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
14001 |
Grave |
Sí |
Parámetros
Parámetro |
Descripción |
---|---|
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
NSName |
Especifica el servicio NameService para el que se genera la alarma. |
Trigger condition |
Genera una alarma cuando el valor real del indicador excede el umbral especificado. |
Impacto en el sistema
El rendimiento de la escritura de datos en HDFS se ve afectado.
Causas posibles
El espacio en disco configurado para el clúster HDFS es insuficiente.
Procedimiento
- Compruebe la capacidad del disco y elimine los archivos innecesarios.
- En la página de detalles del clúster MRS, seleccione Components > HDFS. Se muestra la página Service Status.
- En el área Charts, vea el valor del indicador de monitoreo Percentage of HDFS Capacity para comprobar si el uso del disco de HDFS excede el umbral (80% de forma predeterminada).
- Utilice el cliente en el nodo del clúster y ejecute el comando hdfs dfsadmin -report para comprobar si el valor de DFS Used% es inferior al 100% menos el umbral.
- Utilice el cliente en el nodo del clúster y ejecute el comando hdfs dfs -rm -r file or directory path para eliminar archivos innecesarios.
- Espere 5 minutos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 2.a.
- Expanda el sistema.
- Amplíe la capacidad del disco.
- Espere 5 minutos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 3.
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Referencia
Ninguna